Stuck in BP Fastboot Flash Mode


New Member
Feb 1, 2013
Reaction score
I have a problem that I have not been able to research an answer to after days of searching.

Initial problem was a broken LCD cable which cut the signal to the display completely. I'm not sure how this happened, since it's my wife's phone, but she thinks some paper slid between the display and the keyboard and cut the cable.

I purchased a new cable and installed it. The display now works, but it will only display the BP Fastboot Flash Mode screen when I press the power button. I have tried holding down both volume keys +power, one volume key +power, removing batter, replacing battery, etc. Nothing will allow me to do anything. The display reads:

BP Fasboot Flash Mode (S)

Battery OK
OK to Program
Connect USB
Data Cable

Secondly, in this mode my phone is unrecognizable by my PC. The PC recognizes my working Droid 3 (my phone), but will not recognize nor install the "diag interface", "mux interface", "modem interface", "nmea interface", or "tcmd interface". I have downloaded and installed the Motorola Driver Sets still to no avail.

Thirdly, the phone will not power off once it's in the BP Fastboot Mode. I have to remove the battery. When I install the battery again within 10 seconds or so it goes immediately to the BP Fastboot screen. If I wait longer to install the battery, I will have to press the power button and it will go to the BP Fastboot screen again.

Did I screw up the phone somehow in reinstalling the hardware? I do have a display now, which is good.
Is it possible to recover the system from this point?

Apparently, I need two major things:
1. The USB recognition of my phone to my PC.
2. The ability to get into AP Fastboot so that I can install an OS.

Help me, anyone, if you've got some suggestions.
did you try holding 'm' key and replace battery?
did you try uninstalling device in device manager?

my D3 will not power down in that mode either, think it normal to have to pull battery, if you do not flash in that mode, if you would flash a sbf, or image, it would reboot when done
I have tried installing the battery while holding down "M" and "X" as I read on other threads. It still only boots up in BP mode. The problem with flashing the device at all is that my computer will not recognize the phone. When I plug it in via USB the Device Manager recognizes an "unknown device" and lists all those interface (mux, modem, etc.) but will not recognize them. When I unplug it, the Device Manager refreshes without the "unknown device". My working Droid is recognized as a USB Mass Storage device by the Device Manager so that I can download pics, etc.

Thanks for the effort!
well it was a long shot, but simple fix, if it worked

but [FONT=Verdana, Geneva, sans-serif]USB Mass Storage device, uses a different driver that ap fastboot, in fact every mode uses a different driver, sometimes several drivers
so if your pc recognizes usb mass storage mode, means nothing, as far as any other mode

[/FONT]BP Fasboot Flash Mode is version [FONT=Verdana, Geneva, sans-serif]0A.64, which should mean, phone was running 906 system version
other wise it would be version 0A.53, so you shouldn't flash a .xml recovery image, even if pc did recognized it
but who knows, I know with D2/D2G once on 2.3.4, earlier system versions sbfs, will brick the device, but the system files are still flashed
so that may still be an option, if you can connect to a pc/mac/linux

have you tried a different
[/FONT]pc/mac/linux?[FONT=Verdana, Geneva, sans-serif]

seams likely the lcd flex cable shorted out something, and device can not be fixed
Thanks for the info. I have not tried a Mac, but I have tried different PC's. The cable seems to work fine for other circumstances and I've tried two other cables. I am afraid that I possibly may have simply screwed up the entire phone. Dang. Three months until I can update under our current contract.
yes, that does not sound good

could take apart again, and check connections, but not likely there is a fix