Stuck in airplane mode after putting my phone to sleep


Jul 20, 2010
Reaction score
Is anyone else having the problem of their phone being stuck in airplane mode after putting it to sleep the fix is to turn the phone off but it would be nice if you didn't have to do that do you think it will be fixed in the first software update
Sent from my DROID3 using DroidForums
I haven't had the problem but once the first update rolls through a lot of bugs will be fixed

Sent from my DROID3 using DroidForums
Yep, happens to me.
The first time I drove out of cel service range, the battery ran down quickly, so the next time, I put it in airplane mode, and when I got back to cel service, I couldn't get it out of airplane mode. Had to turn it off... Have to do that every time now. Grrrr.
Mine did that once. I was confused and mad, it was like the 2nd day I had the phone lol. But after about 10minutes the option of to turn it off again came back and hasn't happened since.
Mine gets stucks all the time after coming out of sleep. It will probably get fixed once the first update hits...hopefully
The phone just needs to be rebooted

Sent from my DROID2 GLOBAL using DroidForums
That or I leave it sit for several minutes and it will come out of it. It makes sleep mode pointless though if I have to reboot it or wait for several minutes.
Then it prob loads slow on the lockscreen

Sent from my DROID2 GLOBAL using DroidForums
Mine got stuck in airplane mode quite a few times ... I just kept trying and eventually it worked /shrug
hopefully this update did fix that bug , but if not.. oh well, its not a huge dramatic deal or anything imo
Ohh yea mine just started doing that .. and it sucks really bad cuz I gotta reset my phone. And its like uggghhh!!!!

Sent from my DROID2 GLOBAL using DroidForums
I put my phone in Airplane Mode reception inside my work bulding. I then open it back up upon going out to my car.

The only thing that has ever happened when exiting Airplane mode...albeit in only the 10 days I've had the phone...was the GPS signal wouldn't be I rebooted and was fine.

Sent from my DROID3 using DroidForums
Htc 1 x :This is what I did to fix it, after days with no signal and an Airplane Mode that was on and shutting off at the same time.
1. I got it to off from the phones onbutton, from settings it said "shutting off", made sure that no wifi or mobile data was on
2. I pulled the simcard half way up.
3. Restarted the phone with the simcard that way by pressing the phones onbutton for 10 secs.
4. After rebooting Airplane mode was 100% OFF..yihaaa.Then I pushed the simcard down and put mobile data to "ON".
5. Working!