Solved Strange noise on boot, not charging.


New Member
Apr 18, 2015
Reaction score
Current Phone Model
Droid Razr Maxx xt912
Recently I replaced the screen and battery on my old razr maxx. It immediately began working with no issue until I went to charge my phone. The battery indicator on screen doesn't show that the phone is charging, and the white led flashes briefly when the phone is powered off. Whenever I power on the phone it plays the normal "Droid" sound byte then the usual mechanical noises for the boot animation, but when that finishes it will play a low pitch double beep and then the phone will say "Droid" again. I have tried using the original charger, as well as a new OEM charger. I also have tried soft resetting and holding all three buttons to boot up while powered off. It also is completely off warranty and I do have a new phone, the only problem that phone has is it's a windows phone.
Edit: Trying an FDR right now and wiping everything to see if that solves anything.
Edit: Battery did charge while off and the noise turned out to be the low battery tone. Still doesn't charge while powered on though.
Last edited: