Stock Camera issue


New Member
Mar 29, 2011
Reaction score
I apologize ahead of time if there happens to be a thread concerning this problem. I have been searching everywhere(including here) for a few days now and have not been able to find a solution or answer to my problem.

I have stock Incredible. Any time I try to open the camera, or camcorder, I get a black screen. I do not get any options, the menu does not pop up, and the only thing I can do is hit the home button to back out. If I allow it to sit on the black camera screen for a few moments, the message "Tap screen to activate camera" pops up. However, tapping the screen only makes the message go away. The camcorder does the same thing.

I have factory reset a few times. I have also went to clear any data from the app. When I go to Manage apps and down to the camera, it doesn't even show there is any data at all. No file size for the camera as well. I have formatted my sd card in hopes that was the problem, but that didn't help either. I have also tried to install and use other camera apps. When I try to pull those up, they lock up and force close.

I'm trying to think if there is anything else that I have tried that I'm forgetting. If there is, I will update my post.

Any help would be appreciated. Is it a software issue with the stock camera app? Hardware issue? If it is something I can fix, how would I go about doing that?

Thanks a bunch!
It sounds more like a hardware issue. It sounds like the phone is trying to initialize the camera and recognizes that is hasn't when it comes up with the message.

Is your phone still under warranty, or do you have insurance?
Unfortunately, my phone is out of warranty, and I don't have insurance. I was starting to figure it was a hardware issue. Thanks for the confirmation.

Do you think it is the camera piece itself or the connection on the mainboard? Would it possibly fix the problem if I got another camera and switched them out?
hard to say... when you go into the app does the camera make any audible noise? Usually the camera clicks when it is initialized.
I don't like suggesting this but have you tapped on the camera to see if it might just be stuck?
That I have not tried. How exactly would I go about doing that safely?
Open the camera app then tap the red rim around the camera lens with your finger. Tapping hard enough can damage the camera's auto focus is why I don't like suggesting it.
Ah okay. Well, I can't say I really have anything to lose with the camera right at this moment. haha So, I went ahead and tried that. It did not help though, unfortunately.
The camera is replaceable... as long as you don't mind tearing into your phone you could repair it yourself.
Yeah, I have taken it completely apart inspecting for anything out of the ordinary that might cause problems. I've even taken the camera out once before. I just hope that if I am able to find a replacement that it corrects the issue.

Thanks so much for your help!
Sorry I couldn't be of more help...

Did the camera work after you took it out and put it back? Did it just fail unexpectedly? Maybe an alignment issue of the component on the main board... hopefully it is something you don't have to spend money on.
No, it wasn't working before I took it out or after. I can't really say if maybe it just isn't connecting properly in its housing or what. I can't really tell. I pushed it back in until I felt it kind of click in place though.
i have this exact same issue. would be curious is someone finds a fix. thanks
Sadly, if you are having the exact same issues as I am, then your options are most likely pretty limited. Those options being: warranty replacement should you still be under warranty, insurance replacement if you have it, or attempting to find a working camera part and switching them out hoping that the camera is what is faulty.

I have spent days trying to locate fixes for this problem and came up empty handed.

Did anything happen to your phone before the camera stopped working? Dropped it or possible water damage?