SDmicro file issues


New Member
Mar 26, 2011
Reaction score
I have a Droid X that I picked up two weeks ago and I am unable to delete any files from my SD card. I have used both Astro, and the internal file explorer to delete a file, it shows as deleted and is "removed" from the list, but the files do not actually become deleted. If I restart the phone or plug the phone into my PC the files are all still there. I've tried deleting them when my phone is connected to the PC, and again, Windows (XP) shows the files as being deleted but once I unplug my phone and used either file explorer to double check, they are all still there.

After I ran into that road block, I tried to format my card, to no avail. I don't receive any errors but it doesn't format the card. After I click "Format SD Card" then "Erase everything" the phone does nothing. It just returns to the SD card & phone storage settings page. That's it.

This is my first Droid and after scouring this forum and a couple of others, I have not been able to find anyone that has been having the same problems. Nor any similar problems that had a solution that worked for me.

Any suggestions?

Thanks in advance...