Root didn't work, now phone VERY slow


New Member
Sep 8, 2010
Reaction score
Rooted my wife's D2 using Z4 with no problems. Tried to do same on my D1 with 2.2.2 and didn't work. Uninstalled Z4 and now phone runs very slowly and force closes a lot. Long delays on everything. Any way to fix this without doing Factory Data Reset? Thanks in advance.
You've tried rebooting again and battery pull?

You could boot into recovery and wipe cache (NOT data).
Thanks for fast reply. Yes, have pulled battery and let phone reboot, no difference. Not sure how to reboot into recovery and wipe cache. Can you explain? BTW, I've read many of your posts, Guidot, and learned a lot from you and others on this forum. Thanks.
I've heard Z4 does not work with the D1 and 2.2
I think you may be right, Backnblack. After I had the problem, I searched and found that info. It was sooo easy on my wife's D2 I just thought it would work on my D1. I tried to install 3 times using different methods (astro, email file to self and download, etc...) nothing works. Anybody know of an easy way to root D1 with 2.2.2? I'm not confident enough to try it manually, I need a app like Z4 or something, haven't tried Superone Cllick, does that work on D1 with 2.2.2?
No 1 click rooting methods work on 2.2.2

Sent from my Droid using DroidForums App
Does anybody know if anyone is developing one click like Z4 for D1 2.2.2? and when
The only way to root 2.2.2 D1 is the first link in my sig or Superoneclick, which is found on xda-developers forums, IIRC.
Thanks, Guidot. Just rooted my D1 2.2.2 with Superoneclick. Worked great after going to Motorola site to get drivers. Phone is now very snappy and smooth.