Recently rooted: signature verification failed


New Member
Oct 20, 2011
Reaction score
I'm only posting because I've been working to fix this all night and read so many (aaaaaalmost relevant) forum posts and questions and etc. but can't find anything that helps.

I recently rooted my droid X (did tons of research, pretty proud I pulled it off smoothly.) running 2.3.3, verizon

Only problem is now I can't seem to flash any roms successfully. I tried ROM Manager Premium v4.7.0.5, clockworkmod (won't reboot into recovery mode when prompted and won't finish installing roms after--completely normal no recovery--reboot). I got into recovery mode myself (Android system recovery <3e>) but after wiping and selecting "apply update from sdcard" it said signature verification failed and installation terminated.

If anyone can help me out I'd appreciate it So Much. I'm completely new at this, but trying to learn, so step-by-step instructions are great.

This is the rom I'm attempting to install: ICX for .605 GB
Find Droid2 bootstraper in the market and get it

Use that to get to CWM recovery and make sure you

First make a back up of stock rooted
Then wipe data factory reset
Wipe cache
Then select advanced and wipe dalvik cache
Then select install zip from sd and then choose your ROM your card and install

Don't forget to download and install a gapps (google gapps, market)

Also remember NEVER to install a custom ROM in stock recovery

Sent from my DROIDX using DroidForums
If you follow clueless's steps you should be fine. The only thing I would change is you do not need to flash GAPPS, that extra step os not required for ICX. Some ROMs, such as Cyannogenmod, you need to but not in this circumstance.
But it still doesn't work on the Droid X2.... Does anyone know what rooter will work on the DX2? Can't get Liberty to install. Phone goes in the fireplace if I can't get Liberty.