Please Help!!


Dec 14, 2010
Reaction score
Last night I was Gooling images to use for wallpaper on my X. I tried downloading several but kept getting errors. I rebooted and downloaded 4 or 5 successfully. I went into Astro to try a few and when I tried to delete it would give an error. I went as far as uninstalling and reinstalling Astro. I ended up attaching to the PC via cable and deleting the files. I didn't give it another thought but now I've noticed a can't get into the photo gallery. I think the file structure of the sd card may be corrupt or something like that. Any suggestions?

Sent from my Rooted/O'Clocked X
If you can still access your sd card with your PC, back up whatever you don't want to lose to your PC. Then Format the sd card in your phone (Menu, Settings, Privacy).

Reinstall your backed up files to your sd card. Then you should be ok if the original problem was with the file system (FAT). If one of the backed up files was actually corrupted, then you will have to find out which one is bad and delete it.
So I should be able to copy the entire contents of the sd card to my pc, format, then copy it all back? I won't lose anything?

Sent from my Rooted/O'Clocked X
Had a similar issue after deleting some pictures that I had manually added by my computer. All I had to do was to go in and force the gallery cache to re-initialize. It took me forever to find how to get it done, but it was a thread on here that got me to the correct place.

Now if I could remember what it was that I had to do... it was quite a while back that this was an issue, and has not been an issue since.
Update! I had made a straight copy of the entire contents of the sd card just a few days ago. So, I went ahead and formated the card from the phone then copied everything back from the pc copy. It seems ok and I can now get into the gallery and view pictures BUT the thumbnails are all generic. Please HELP!

Sent from my Rooted/O'Clocked X
I just went and tried to delete all the thumbnail files in the thumbnail folder under sdcard;dcim but Astro throws an error when I try to delete. I downloaded an app called gallery to see if it would process the pics correctly and it says the sd card is unmounted. I even went and unmounted the card and remounted it. Astro can view files and the built in gallery will display my pics but the thumbnails are still the generic thumbnail. Please help.

Sent from my Rooted/O'Clocked X
Anyone? Please help!

Sent from my Rooted/O'Clocked X
Go to Menu, Settings, Applications, Manage Applications. Select the All tab at the top. Scroll down to Gallery, then tap on Gallery, tap on Clear Data. Ignore any warning messages that data will be lost.

Press the Back hard key, scroll down to Media Container Service, tap on it and Clear Data, repeat for Media Storage.

Reboot the phone and let the databases and gallery reindex, it can take a while. Everything whould be restored and good to go.
I followed instructions exactly. It took about 2 mins for it to reload the pictures. The pictures are there and I can view everyone but the thumbnails are still the gray generic pictures! I even tried doing your steps twice. Anymore ideas?

Sent from my Rooted/O'Clocked X
Got it fixed!!!!! I formatted the SD card and then manually created the dcim\camera file path. I then checked and the gallery said no files. I then moved one pic from my pc backup over to the folder and unplugged and checked it. It built the thumbnail correctly. I then hooked the cable back up and copied the remaining 230 pics and it built everyone again. The only folder I built was the dcim and camera folders. It automatically created the thumbnail folder. I hope this helps someone else down the road.

Sent from my Rooted/O'Clocked X