PdaNet + Mac OSX + XBOX = Fail


New Member
Jan 30, 2013
Reaction score
I have a Motorola Razr Maxx and a grandfathered unlimited data plan through Verizon. I get solid 4G coverage at home, and I'm trying to explore the possibility of using my phone's data as a replacement for my Comcast ISP.

I am running PdaNet+ 4.0.3 and tethering via USB to my MacBook. The internet works fine on the computer (I'm using it now as I type this), but I'd also like to connect my Xbox 360, which is giving me problems. I've enabled internet sharing from Pdanet (en2) to Ethernet, and connected the XBox to the MacBook's ethernet slot. I've tried this 2 different ways - direct connection and via a Linksys router. Neither method has worked. When I use the direct connect, the Xbox' automatic settings can't detect my ip and other necessary numbers, and when I use the router, the router assigns the ip and the xbox can see the local network, but it keeps getting a DNS error. I wrote to the pdanet tech support people and they sent me a generic response that said to download a legacy network driver, but it was geared toward PC users instead of Mac.

I know the internet sharing function works, because I tried sharing from pdanet to the AirPort, and when I do that I am able to watch streaming video on my wifi-only ipad. The problem has to be something to do with DNS settings on the shared ethernet port. I've done dozens of google searches and read lots of forum posts that are kinda sorta similar to my problem, but have not found a solution. I am a novice when it comes to networking and I only just made the switch to Mac about a month ago, so I'm not entirely familiar with my machine yet.

Anybody else had this issue? Advice would be appreciated.