No fastboot mode at all?


New Member
Jul 19, 2014
Reaction score
Current Phone Model
Micromax Unite A092
Hey guys,
I post here and I'll try to keep it as short as possible while including all possible details regarding my situation.

I was gifted a Micromax A092 a few days back. Qualcomm quad core processor, 1GB Ram, Jelly Bean 4.3.

Well after rooting it somehow(nightmare) and installing SuperSU and enabling USB debugging, I have hit a brick wall with fastboot mode. The Vol down + Power button combo gets me to the logo screen where it stays till I am forced to pull the battery out to reboot.

Phone does get detected under Device Manager while its stuck on the logo screen and I can install drivers to get it to show up as Android ADB Interface or Android ADB Composite Interface but fast boot refuses to detect it even though adb does when connected normally and executes all commands properly.

Well here's a list of things I have tried:

15 seconds ADB Installer - check
Minimal ADB and fastboot - check
Android SDK with google drivers and unnecessary packages - check
Universal naked drivers - check
Modding the inf files with my devices hardware id's - check
Pdanet+ driver installation method - check
Mobrobo/Mobogenie - check
Manual driver installation - check
Different USB cables - check
Few other random hacks - check

Later gave adb sideloading a shot hoping I could flash a custom recovery onto it via command prompt. No dice there either. Being unable to flash anything means I am still rocking "android system recovery 3e" as my recovery mode which in turn means the dreaded signature verification failed message trying to install 3rd party apps in recovery and sideload mode. I have also tried installing a couple of these custom recovery modes via .bat files but I guess its failing due to the same damn signature verification reason.

Now I know all phones don't ship with fastboot mode but given that this phone was released just a couple of months back and 2 year old inferior phones from Micromax have said feature gives me hope that maybe there indeed exists a way to flash it.

So am I messing up somewhere? Or does the phone not have fastboot mode at all? Coupled with the fact that the retarded default recovery mode won't allow me to load custom apps in side load, what other options do I have? A little help please...thanks.


New Member
Jul 19, 2014
Reaction score
Current Phone Model
Micromax Unite A092
Also here's a recommended .bat file for apparently flashing my phone that I found after digging around a bit -

@Echo off

adb reboot bootloader

echo for not erase modemst1 and modest2

rem fastboot flash partition gpt_both0.bin

fastboot flash aboot emmc_appsboot.mbn

fastboot flash sbl1 sbl1.mbn

fastboot flash tz tz.mbn

fastboot flash rpm rpm.mbn

fastboot flash sdi sdi.mbn

rem fastboot flash fsg fs_image.tar.gz.mbn.img

rem fastboot flash modemst1 dummy.bin

rem fastboot flash modemst2 dummy.bin

fastboot flash modem NON-HLOS.bin

echo for not erase bt and wifi information

rem fastboot flash persist persist.img

fastboot flash cache cache.img

fastboot flash usbmsc usbdisk.img

fastboot erase splash

fastboot flash splash splash.img

fastboot -S 256M flash system system.img

fastboot flash recovery recovery.img

fastboot -S 256M flash userdata userdata.img

fastboot flash boot boot.img

fastboot reboot

Seeing a lot of fastboot commands there which means there might be a fastboot mod after all?

One more question - what's the difference between fastboot and bootloader mode? I can reboot in bootloader mode via adb commands but it still sits at the company logo screen.