Netflix help please?

Dec 28, 2009
Reaction score
I installed netflix on my d2 and when I try to watch a movie it will play for one second, and than it will just stop playing and go back to the screen that lets me choose a movie to watch. I have tried a dozen movies all producing the same results.

Anyone know a fix?

Is it because I am rooted?

I have installed netflix twice now. I have tried it on both 3g and wifi.

Movies start, play for 1 second, and then stop playing.

Please help.
It seems like this same question is everywhere, however there is never a reply. Go figure.
Have you downloaded the updated one in the market?
I've posted this in at least 3 threads. I'm surprised you haven't seen it. Either it doesn't work for you or you didn't look that hard. I'm rooted on a d2 (froyo) and it works great. Get it now cause I'm taking this link down later this evening most likely. I need to free up space on my dropbox acct

From my Liberated DROID2 at 1.25ghz
BacknBlack, the netflix app does not show up in the market for me.

Idopa, Yes I have tried your download along with 3 other downloads, all producing the same results.
My thought is maybe because you are using a rom? idk.

SpaZZoiD, are you stock? Rooted? Running a Rom?

Thanks for the replies guys, that gives me a little hope that I will be able to get this fixed.
Hope so. I would not be happy if all these dl weren't working.

From my Liberated DROID2 at 1.25ghz
Yes I'm rooted and using liberty rom. Its still working for me but I been getting a updated message. But I can still use it. I'm looking for the latest version now. Can anyone help

Liberated droid2 at 1.5ghz