Need help with re-rooting Galaxy Nexus after 4.0.4 update


New Member
Dec 29, 2011
Reaction score
Hey all, I know I'm a bit late to the party, but since I wasn't paying attention, I didn't realize until last week that my phone lost root access after the OTA update to 4.0.4. I originally unlocked the bootloader and rooted with Wug's toolkit: Nexus Root Toolkit v1.5.2 | WugFreshI have the right drivers installed (at least the ones I used to root it 6ish months ago) and didn't change a thing on either of the 2 computers I've used to access this phone. I made sure that USB debugging was still enabled and tried to re-root using Wug's method just now.

However, my computer no longer recognizes my phone. I tried both computers (which are running Win 7, one 64 bit and one 32 bit) and 3 USB cables, and I can't get my phone to pop up in the device manager anymore, nor can I get Wug's toolkit to work.

My phone still charges when connected to the computer via the OEM cable and both of 2 other cables I've tried using (generic cable in the Costco package that came with my phone and old Moto Droid 1 cable). It seems that it will pull power from a USB port, but for some reason the computer won't recognize it.

When I go to reinstall the Samsung drivers, my computer says they're already installed. I uninstalled PDANet, but now it won't let me reinstall because it doesn't detect my phone when I plug it in. I did reinstall the Samsung drivers manually despite that and nothing changed.

I am having slight issues with the USB cable in general (whether plugged into the wall or a computer) - I dropped it too many times and ended up having to bend the cable in a certain direction to make it charge. Other cables charge it without any issues. Could this be a cause? Maybe it was my only usable cable for this purpose and it's dead? Could the solution be as simple as getting another OEM cable?

Any help would be appreciated. Also, if you know of a way to re-root my GNex without using a PC connection, I'd appreciate being able to have root access again for the time being while I figure out the PC connection issue.
Actually just realized I should have posted this in the GNex developer forum. Is there a mod who can move it for me? Sorry for the trouble.