My SBF nightmare!!! UGH! Help please!


New Member
Aug 26, 2011
Reaction score
Okay, here we go. This is my first post but I have some experience with rooting, sbfing, roming, theming, blah blah blah. Anyway, I have a Droid 2 Global which I had picked up pretty cheap because the person didn't want it anymore as it's stuck in the bootloader screen. Easy fix right? I loaded up RSDlite 4.9, downloaded the sbf file - specifically for droid 2 global 2.4.29 AND for safe measure, I downloaded 2.4.33 as well.

Every time I've attempted, it freaks out. Let me explain - Every post I've read in regards to the droid 2 global, what SHOULD happen is the phone should reboot and possibly go into a boot loop, which at that point, I should be able to go into the stock recovery screen by holding the "x" key and pushing power to wipe data/cache. However, it won't even go into the boot loop. When the phone reboots, there's no M logo, it just goes back into the bootloader screen - despite the fact that RSDlite states the flash is complete! The exact same thing happens when i tried to sbf the 2.4.33. I've uninstalled and reinstalled RSDLite, uninstalled 4.9 and went back to 4.8.. which I received some error message.. later to read that 4.8 won't work with the A956. So I uninstalled 4.8 and reinstalled 4.9. I uninstalled everything that says motorola, all drivers, so on and so forth, reinstalled... nothing.

I did read someplace that I could try to sbf a different bootloader but the link which was posted was broken so I couldn't even get the file and even if the file was available, I'm not sure how to sbf a different bootloader to begin with.

I've tried different USB cables, I've tried different USB ports, I'm out of ideas other than the fact I have a paperweight.

So please please please, any help/feedback would be greatly appreciated!!
Here's what I have:

Motorola A956
Windows 7 32-bit
Motorola RSDlite v4.9