Motorola Photon Q 4G LTE no longer recognized by any computer, laptop, etc.


New Member
Sep 12, 2013
Reaction score
I was using my Android yesterday to transfer photos and videos from the SD card to my laptop. My USB cable was flaky and I planned to replace it, however I was trying to finish a project that night. It cut out a couple times during the transfers and I had to start over.

Today I got a new USB cable, and suddenly the laptop wont recognize that anything is plugged in to it at all, but the phone will be charging. Tried several cables, several computer. Phone charges on all of the good cables, and no computer recognizes it. Took it to the Sprint store, their computers didnt recognize it either, and they couldnt give me any advice other than to hard reset the phone.

My Android software is up to date. My computer drivers are up to date. I've tried a million other things, I cant remember at the moment, but I probably will after you guys say "have you tried this"?

Hard reset is a last resort. What can I do?