I think I totally messed up my SD Card.


May 24, 2011
Reaction score
San Francisco, —————— California
So I decided to replace my ext3 partition (which was made using rom manager) to an ext2 partition using MiniTool Partition Wizard because Rom Manager makes it ext3 my default. So with 00:00 experience of linux and all that confusing stuff I thought it would be easy enough just to replace it by right clicking, and create a new partition that was 512mb. And I successfully did, until I put the SD card back into my phone and my phone couldn't even read it. It said it wasn't even mounted.
I then went back to the MiniTool Partition Wizard and played around with it. I started deleting partitions and ended up deleting the FAT32 partition of the actual SD Card thinking that making another would help. Instead, it was made and had about 7mb left of allocated space which I had no idea what that was and I couldn't even remove it. So I removed the partition again, and now my SD card is really just messes up. It shows up as "BAD DISK" on the Partition Wizard and there is no options to partition or anything. My SD is toast.

Any ways to get it back up and running like it came out of the box?

Note: Windows can't even recognize it anymore since there is no file system on the SD anymore. No FAT32. Just 16gb of "allocated space"
Last edited:


New Member
Sep 8, 2012
Reaction score
I think I know the solution.

I know this might be a bit late but I just had the same problem a while ago and I solved it I am not sure we are experiencing the same thing but mine was pretty simple I think I selected logical instead of primary in the menu after I clicked apply so it should be primary instead of logical I think thats the reason the phone wasnt picking up the memory card if you already fixed it though I would love to know what was your solution so I can know what approach to take next time the problem occurs.