I am a stupid D2G N00b, please help


New Member
Mar 29, 2011
Reaction score
Okay well here it goes, hopefully I dont get pwn'd out of the forum.

I have recently rooted my D2G, everything went fairly well, I was even able to play around with installing a couple ROM's (Fission/Liberty). However after deciding that I didn't care for either as they both had too many bugs to work smoothly on the D2G I simply reverted to the 2.2 OEM OS.

Now here is where my n00bish stupidity comes in. I was aware of the risk of boot looping and/or bricking the phone, especially when booting with low battery. My D2G for some reason decided it no longer felt the need to hold battery and would only work while plugged in. Needless to say I was booting it, the charger must have sliped out during boot, thus leaving it in a boot loop.

I am able to access the the screen with the explanation mark and the droid man (that is the correct terminology right? lol) by powering on while holding "X", and then holding the search/magnifying glass button to enter the recovery screen. I "Wipe cache partition" and then "Wipe data/factory reset" and then "Reboot system now".

This all does absolutely nothing, it simply enters the boot loop again.

I have searched and tried a few things but nothing is working and im growing incredibly irritated with it, I am debating spiking it like a football in the street if I cant figure it out soon. PLEASE HELP!!

Sent from my iPhone. (Joking)
I would SBF it. There's a few threads around here on SBFing how-too's.
yes sir buddy SBF from TBH is also my suggested commit to you and yes more then enough threads here to get you going on that also make sure you battery has a full charge just to be safe
For the D2G noobs (I'm one too), I compiled a helpful thread here that should answer your questions, with helpful links.
To OP - since you went thru Liberty, the only true way out is to flash official SBF and wipe data and cache afterwards. Follow sticky thread here on where to get SBF and how to perform the flashing.

I have searched and tried a few things but nothing is working and im growing incredibly irritated with it, I am debating spiking it like a football in the street if I cant figure it out soon. PLEASE HELP!!

Sent from my iPhone. (Joking)

I know this doesn't help anything, but it is good to see that even in your frustration you still have a sense of humor! I really like to iPhone comment- too funny!

Seriously though, I hope you were/will get your phone back soon.
Thanks for all the input, I guess the consensus is that I will have to flash it with the SBF from TBH. I have downloaded the SBF file, and I understand that I will have to boot into bootloader mode however when i do so it flashes at me "Battery Low, Cannot Program".

This makes sense all except that the phone has been plugged in for 24 hours and is currently plugged in while im booting . . Like i said i was having battery issues previous to the boot loop so what do I do now??
False alarm, I found an old BP6X battery from my original Droid that has full charge and is allowing bootloader to run.

It says "Ok to transfer, transfer mode: USB" and I have the SBF files downloaded.

I have downloaded RSDLite version 4.5.3 because the link for version 4.9 is no longer active?
It reads my device and I select the SBF file and click Start, it then says "Failed Flashing Process" in the status section.

I have no idea what to do. Am I doing something wrong?
Last edited:
I think you need the most up to date rsd lite, if you want pm your email and i can send you it. hope we can get this working for you. pst even the most seasoned vet is noob at one time
Ironically I was JUST able to find RSDLite 4.9, it will not read my device though . . I have the most current Motorola drivers (4.9). My computer will not even recognize my phone. SO frustrated.
dam that sux i am sure there is a way are you able to get into the bootloader?
My phone is in bootloader mode. When I plug the device into my computer via USB, the drivers pop up and say they were installed correctly but the Moto icon is not in the tray and neither my computer nor RSDLite is recognizing the device.
Why won't RSDLite recognize my D2G? I have version 4.9 and the most current Motorola drivers. When I turn my phone on while holding the up arrow to enter Bootloader mode, this is the screen that I get, is this what I should be looking at?

Have yot rebooted the computer after you updated rsdlite? Try to do so.

Sent from my DROID2 GLOBAL

ok umm try running RSD lite as admin maybe? dont know what ver. of windows you have but that might solve your issue and yes that is the bootloader for rsd lite to work, and also the Moto logo in you tray area in windows is called Motohelper.exe make sure you or someoneone haven't disable that service. I know it conflicts with a few things I run on my PC good luck
Last edited: