Htc_One(4.4.2)USB_Win7_Tethering (Drivers Fail)


New Member
Sep 18, 2014
Reaction score
Current Phone Model
HTC One M7
So here is my journey so far.
I have the HTC one M7 from T-Mobile.
I think T-Mobile has great service so far (unless you are out in the country then LAME-O) that aside i have loved this phone from the beginning.
Until now!
I travel allot for work and have to be in hotles where the wifi speeds are sucktastic. So i thought i will use my phone to tether.
Remembering the times of my G1 and how i rooted it i thought perhaps that is what i would have to do to get the full use of my unlimited Internet package as the tethering max was at 5 gbs.... not enough, not nearly enough!!
So i sought a friend who was using PDANet+ to tether his Samsung phones via USB.
It was so simple watching him set it up.
Start the PDANet application, the newest one asks what the maker of the phone is, then it installs a driver for your to use (ADB/MTP/CDC), Plug in the phone when it tells you and boom. All set.

I went home with full expectations of using my phone for streaming.
Downloaded the App and paid for licenses as i saw how awesome it was on my buddies machine and i thought there would be no issues as he is not rooted or special rom either.
Much to my chagrin i was quite wrong.
I hooked up the phone, it didn't know it was in debug mode so i de-selected debug and re-enabled it. The Driver installer poped up and was showing a few drivers that it was trying to install.
It wouldn't install (MTP/RNDIS/CDC) so could not make a connection.
Crazy thing is i would get the prompt asking me to trust the security key from my computer to communicate, but then no tethering.

So i read some forums and i read some more forums and i un-installed everything. Downloaded HTC Sync, installed it, installed pdanet again, went to install and this time a little different behavior.
I could see my phone in the device manager as an Android ADB device but yet when i would click connect on the PDAnet settings it would tell me to turn on the app on my phone. Well the app is on and debug is on and tethering enabled is on.

I have already used up my tethering data so dont know if that is playing apart of this when it comes to allowing a driver to install ? Perhaps a service needs to be active that is not that is required for the driver to install ??

So here i am with my M7 4.4.4 on windows 7 enterprise 32 and it will not install the drivers needed for this phone.

I tried with Samsung galaxy s3 and s5 both worked flawless on 4.4.2 USB tethering.

I got it to do the same thing on the M7 with Bluetooth but it drops after so much time.

Any thoughts here fellow enthusiasts cause i am out of dice rolls.