How to delete .apk files using Terminal Emulator

HamDog

Member
Joined
Aug 3, 2010
Messages
190
Reaction score
0
I posted this in the Hacks forum but never got a response. I'm hoping someone here can help. I have the original Droid with 2.2 and rooted (stock ROM and kernel). I have watched videos of people deleting stock .apk files (e.g. Twitter) using Terminal Emulator, but it doesn't work for me. Here is what I'm doing:

$ su (enter)
# mount -o rw,remount /system (enter)
Usage: mount [-r] [-w] [-o options] [-t type] device directory

Don't know what I'm doing wrong in the command line. Obviously, there is something wrong with my command line as the next line is telling me the correct way to use "mount".

If that had worked, the next line would be:
rm -r /system/app/Twitter.apk
I tried entering that line anyways and I get the message that it failed because it's a Read-only file system.

So for some reason, I can't mount and change it to a read-write file.

I know I can use Root Explorer or ADM to accomplish this, but I want to do this using the Emulator (for learning purposes). I also know that I can rename it instead of delete, but it won't allow me to rename it either since it's a read only file.

Any help is appreciated.
 
Thanks, but that didn't work for me either. After typing "sysrw", I get the message "sysrw: not found".

Since that message is from a custom ROM (cvpcs) discussion group, I'm thinking maybe that command works for that kernel, but not the stock rooted kernel?
 
The sysrw/sysro commands are scripted in by Dev's

Try this


su
mount -o remount,rw -t yaffs2 /dev/block/mtdblk3 /system
rm /system/app/Gmail.apk
reboot
 
Try this

su
mount -o remount,rw -t yaffs2 /dev/block/mtdblk3 /system
rm /system/app/Gmail.apk
reboot

IT WORKED! Thanks! Now I need to buy a Linux book and start learning what the heck I just did and whats "yaffs2".

Thanks again!
 
Back
Top