Feb 5, 2011
Reaction score
Ok I think I bricked it. Its stuck at the logo and I can't get it into recover mode. I don't care about root or anything I just want the thing to turn on!!! Please help!!

Sent from my rooted Droid Incredible rocking cm7
I can't get it onto recovery??

Sent from my rooted Droid Incredible rocking cm7
I can't get it onto recovery??

Sent from my rooted Droid Incredible rocking cm7

Question, did you go and do the OTA update released this week? The recent Droid X one kills SBF to earlier builds and I'm not sure if it does that here. I can still get into boot-loader mode by holding the up button on the keypad BEFORE I power it on.

Edit: Also, if you have the time to do this, I recommend using this tool

If you're having problems with using RSDLite. This boots your computer up in a Linux Live CD so you can SBF your phone more easily. I've done both, and this is far easier to deal with than RSDLite.

However, this is an older SBF, so be warned, that if Motorola had blocked SBF'ing back to earlier builds like they did with the Droid X, it might not work.

Also, one more thing to add in here.

I got this at a local staples, but you can order it online:
This allowed me to charge my battery when I got the "Battery Low Can't Program" error, when your battery is too low and it won't charge through normal means. It's cheaper than getting a official battery charger, and easier than cutting up a USB cable and tapping the ends together. This will flash green when the tips are connected at the right spot. It worked for me.
Last edited:
You cannot flash images that aren't 4.5.629+ to a phone that was updated to 4.5.629. Period. It's not about “if”, it's about the fact that they did block downgrade.
I can't get it onto recovery??

Sent from my rooted Droid Incredible rocking cm7

Well damn, that sucks. Didn't they make a recent SBF file for the Droid X that does work post update?

Edit: Checked, and supposedly they did for the Droid X. Guess you have to wait for the D2G SBF then if you did the recent OTA update. If you didn't, you're still in luck.
Last edited:
Wait when I have it hooked up through USB I can get it to go into recovery but it does the batt low cannot program. I figured it was crazy cuz I had the phone plugged up all night but is it possible that the phone wont charge when off for some reason?

Sent from my rooted Droid Incredible rocking cm7
First off, if you did the recent update right now, SBF'ing won't work period it seems. AT least until a new SBF is leaked that works as Gasai Yuno stated.

Anyways, as I stated in my previous post, you're going to need to charge that battery manually. It will NOT charge VIA USB from my experience. Something to do with the system not working, or the usb power supply not being enough to charge the battery in bootloader mode, or something. Either way in my experience, USB CHARGING... WILL... NOT... WORK!!! (If and When you SBF successfully, then it will work again.))

You can look for a motorola direct battery charger online, but they aren't super cheap. At least they are meant for your battery. I did mine with that tool I listed, the Lenmar battery charger clip, and it worked for me. It was like, 5-9 bucks at Staples in the United States, and can be ordered online. But be careful with it, and make sure both tips are touching, which are the outside spots on the battery. The clip will turn green if you got it right. Let it charge for about a half-hour or so.

Or, you can get a new battery, and hope it was pre-charged already. At Verizon stores, most are charged to at least 50%, which is enough for you to SBF. I know from experience since that was what I did first. (I got the battery free though.)

Or you can look online and cut up your charging cable and tap the ends to the battery. I don't recommend this, since even though it's basically the same method as the clip charger, you still gotta deal with human error and such. At least the clips will light up if you got the contacts in right before you plug it in. I don't recommend this, but hey, it's your battery.

Or you can send your phone in.

However, all of this is useless right now if you did the apparent update, from what
Gasai Yuno has stated.
Last edited:
I don't think my mom did the update. Its her phone so I doubt she did it, and thanks for telling me about that experience. I found an old charger that outputs 4volts and will be charging manually. Don't worry about me messing up and connecting the wrong wires I've had an electricity class so I get it. I will tell u if it works

Sent from my rooted Droid Incredible rocking cm7
Good, oh and I made a new thread about something I just discovered works again with the newest update, at least for me. The factory recovery image setting, the one with the android logo and the triangle with the exclamation point on it, I got it to work and wipe cache. Apparently, instead of pressing the Magnifying glass like you did before, you press both volume up and volume down at the same time. Something useful to know if you use a later GB and it keeps bootlooping after SBF'ing, you'll need to wipe cache.

Edit: Yuno here enlightened me that this was already known with the GB update. So my bad, but at least I can say it works with the update. :D

Edit: Also, someone said that they had gotten the wall charger to work. Maybe it's them, but I never got it to work for me. Take it with a grain of salt.
Last edited: