[help] HTC One M8 bootup stuck at boot animation


Active Member
Jun 9, 2010
Reaction score
I have the new HTC One M8, rooted, with latest TWRP, and I managed to possibly get myself in a pickle. I'll explain what I was doing, because I'm not actually sure what could have happened.

I've been working on boot animations and trying to see what this phone can do. I wanted to see what the phone was thinking while playing a boot animation, so I installed CatLog and aLogcat. CatLog was showing a tremendous amount of information, but would crash if I tapped in the search field. I noticed a lot of wifi information, so I turned on plane mode. That helped, though GPS came on soon after, which I wasn't actually aware was normal, but I tried to turn that off too, via the stock settings shortcuts in top right of the notification bar. It refused to disable, so I went further into settings and tried to disable it for location access. When the GPS continued to appear to be in use, I got annoyed and rebooted the phone (hold power> restart). Now, my phone seems to freeze at the end of the boot animation.

I rebooted a couple of times to be sure it wasn't a fluke, both plugged in and unplugged. My next reaction was to wipe dalvik and cache and reboot. Same behavior. What now?

I have not yet made a nandroid backup, as I haven't made any mods to my phone, well accept for unhiding power saving mode and extreme power saving mode in the settings, but they have remained disabled and the phone has run fine for a week or more since.

I'd love to not have to wipe data, for obvious reasons, but is there any other options to try before this? Is there possibly anything wrong with the radio with the behavior I described before rebooting it?
I thought maybe this was a general android issue, as apposed to one specific for my device. Nonetheless, related to my device, there isn't a way to mount /sdcard from recovery and have it be available via adb, correct? I was trying to see if plane mode remained enabled during a reboot, and was going to attempt to disable it, or re-enable radios then boot up. While in TWRP, I was able to copy the databases from /data/data/com.android.provider.settings to /sdcard, and was going to try and modify on pc and return. Not much to go on but this link.

Well, I am not sure how much anyone can help at this point. I'd love to have this resolved before I leave work, since it will likely be a few hours before I can look at it again. I think I'm going to wipe data and leave the evening to resolving things from there.
Okay and I'm back. No wipe needed. One last reboot before I wiped and it completed the bit animation and preceded to rebuild after the dalvik and cache wipes I did a couple of reboots earlier. It makes no sense.

Sent from my HTC6525LVW using Tapatalk