Solved Google Play won't download or update


Aug 20, 2010
Reaction score
I haven't messed with my phone at all for 4 months now, but suddenly it wouldn't download any MP3's. I tried installing a different MP3 program and learned that it won't download anything through Google Play. It won't even update any of my other apps. It's a Galaxy S5 with root, nothing else.

I've tried doing a complete phone reset (without wiping my apps though). I've uninstalled Google service and Play updates, had to download the APK's manually to get it back to the new version. I've cleared Google play and services cache and data multiple times. I've closed and reinstalled my google account on the phone several times.

The browsers all work fine, they operate and download perfectly. My hotspot is working well too, no problems. But any app that needs to download including google play, will not download.
First, try clearing the cache in the Google Framework app under all in the app manager. Then force stop and restart. Then try to use the same creds you are using on the phone to access the Play Store through a browser. See if it is listed under my devices or if you can pick an app to install to it from the WEB.
Ok, I tried those things and still no luck. It finds my device from google play on a PC, but will not send any apps to the phone. It also gives me an error when rebooting the phone that says "Unfortunately the process has stopped". It repeats that error once more right after the first time I clear it, then it goes away.

I've never allowed google to track my location, but for troubleshooting I turned on location and google location sharing etc. Still no luck. It seems kind of fishy that just hours ago there was a new article stating that Google just finally released an update to the Google play store, and now my google play quit working. Even after I manually updated it.
I don't have a clue, but you did mention 2 things in your first post that prompt me to ask questions. You mentioned you were rooted. What did you use and did you do anything at all to the system after you rooted? Secondly you mentioned having done a reset without disturbing the apps. A complete reset (factory) will uninstall any apps you had installed (along with data) and put it back to factory fresh. That may not be a bad idea.
I rooted it just so I could install the "Xposed" app which allows me to use the wifi tethering without being ripped off by Verz. It's been fine for months, but suddenly they do an update to google play and it stopped working. Mine hadn't been updated by the OTA, but still didn't work before/after me updating it.

I may have to do a complete reinstall of everything, but will take up a lot of time. I read someone else who had the problem caused by incorrect APN setting because somehow it had changed, or the provider changed their address and it didn't update that into the phone.....any ideas with that ?

I don't feel the/any APN changes had anything to do with with it. I do know that the problem you are describing is one I haven't seen before based on what you have tried. It may have been the Store update, but possibly because something else wasn't stable before hand. You could try CleanMaster (by Cheetah Mobile) to see if it might help.
I fixed it finally, but had to reformat everything. I ended up installing Alliance ROM and reinstalled my apps. Not sure what caused it in the first place, with a stock rom, and never really messed with any settings for months. Just happened to take a dirt nap within hours of Google updating it's playstore.......BUT I'm happy with Alliance so far, the phone is much faster and I feel that I have much more control of it.