Marketplace won't download any apps.


New Member
Nov 23, 2010
Reaction score
Hello everyone. My Droid X stopped downloading apps today. The downloading icon appears in the notification bar briefly, maybe 2-3 seconds, then disappears. I successfully downloaded a couple updates, as well as a manual update to Google Maps (from the system version 4.4 to 4.7) and it's been happening since then. I've rebooted the phone, removed the update to Maps, rebooted again, and tried to download multiple different apps and the same thing happens every time. Any ideas? Thanks.
I believe I have found the problem. Version 2.12 of Market seems to be causing the issue. I went to Settings --> Applications and "uninstalled updates". Then I was able to download apps again. The only problem is that this version auto-installs itself so before I was able to download all my updates the 2.12 version of Market was installed again, and I had to repeat the procedure to finish. I assume it's a bug with this version that will be corrected shortly.
I can confirm x2jroy's fix comment. However, this doesn't happen on every Droid X.

I have a Droid X and do not have this problem. My girlfriend's Droid X started failing at downloads (the same way x2jroy described in the original post).

From Home screen: Press the physical "menu" button on the phone and select Settings from the popup menu.

Navigate to Applications >> Manage Applications >> Market (under the Downloads tab).

If the version is 2.12 AND you are having this problem exactly as described (download icon appears for 2 seconds in the droid menu bar then disappears without warning or error), then the fix is to hit the Uninstall Updates button (next to Force Stop button at the top). This will only remove updates to Market, it will not uninstall the whole app. This does fix the issue of being unable to download.

Using the Uninstall Updates button alone will cause you to have to Agree to the Market Terms of Service; that's how you'll know your next download should work.

Oddly, if you go back to market after downloading anything successfully, the version of Market is back to 2.12, and downloads will once again cease to function until you repeat the fix above of uninstalling Market updates. Then you can download one more app. Rinse, repeat, rinse, repeat.

I don't know if using the "Update All" button will work after this fix, or if it will crap out after the first completed install.

Very annoying. :)
Last edited:
this is happening to me too.

do you think this issue will be fixed, so we don't have to keep pressing "Uninstall updates" after every app?

I thought this was only my phone. xD phew.
this $hit still doesnt work.... I have tried it all...
I still get error message 18 when tryign to download!!
it downloads but upon InstallingI get an error message........