Google Navigation Fails To Lock Location


Jun 26, 2010
Reaction score
New York
This issue started over a month ago and is really starting to bug me.

The History:

I was running a Stock Rooted 2.2.2 rom with some of the stock bloatware removed. I wanted to try something new so I planned to install a new rom. I did a full wipe of data/cache in SPRecovery and flashed an older Froyo Miui rom. Upon going to use Navigation one day, my phone could load directions and I could view them but my phone would be stuck on "searching for gps". Maps was accurate to my location within a mile but would never fully lock. I then did a full wipe of my phone and returned to a nandroid backup when I remember gps working. Still the same problem. So I did a full wipe and flashed a fresh rom ... Still no fix. I tried flashing a fresh rom and creating a new google account (Idk why) and still the same problem.

I downloaded one of those gps status apps from the market, and it take my phone almost forever to find satellites in the sky and when it does it never locks on to any. I have tried Waze Gps, and Mapquest and neither lock my location. Every now and then when I am 30+ miles or so away from home the gps will work. Not all the time though. I don't understand what would cause this.

I called VZW and was told that it is a google issue and that they would offer me VZNavigator for free until the issue is resolved. I denied their offer seeing as no other gps app seems to work for me, why would theirs?

My Phone Info:

Original Droid
Android Version: 2.2.2
Baseband Version: C_01.43.01P

Anybody have any idea what is up? I live in Columbia County New York and I find that the gps rarely works within my county. Heck it rarely works at all. Is it something I've done to my phone that has caused this, or was the person I was talking to at VZW correct, and this is a google issue?

All help is greatly appreciated!!!!!