GB Black Screen, goes unresponsive after a little bit of use


New Member
Jul 20, 2010
Reaction score
So, I'm currently running Liberty GB v0.8, but this problem also occured with ApeX 2.0, so I don't think it's necessarily the rom. The problem doesn't occur immediately, just after some time of use (a day or two) then it happens non-stop.

Description of the problem:
The phone will be turned on and whatnot, then, I might get some errors with some apps, nothing overly crazy but when I hit the turn on/off button, the screen will go black and will not go back to normal if I press the button again. At first, the white lights light up (like the home button, back button, search button) and I can 'turn them off' by pressing the on/off button again but then after a while, they won't even turn on by pressing the button again. The phone will be completely unresponsive until I pull the battery and reboot.

Sometimes it won't even show any errors. If I just leave it on and the screen shuts off because of idleness, I won't be able to turn it back on again.

When I say "some errors with some apps", I don't mean to imply that the apps caused it (since as I noted before, this can happen even if no app is running). But rather, let's say I try to open Mixzing, then it'll either FC or if it was already running, the song will stop playing. I can still use the droid so long as the screen is turned off, but almost no app will work. While I was using ApeX, for example, I couldn't even run Droid 2 Boostrap. Well, I could hit the recovery, but when I tried to reboot it FC'd.

Attempts at Solving the Problem:
This problem originally occured to me in ApeX 2.0 and at the time I thought it had to be the rom or something, because I tried various factory resets, wiping cache, dalvik cache, etc. I did manage to fix the problem by SBFing back into froyo, and that seemed to stabilize it nicely. However, I was determined to try ApeX, so I tried it again, this time using a different GB leak (the 2 part thing by Team Black Hat) then used ApeX again and it seemed good enough but soon enough, the same problem occured.

So, thinking it was the rom, I just SBF'd yet again, went to GB again with the same leak, and tried Liberty GB v0.8 and this one seemed really promising. No error, and it seem to last a few days, but just right now, the problem creeped up again : (.

So, I'm clearly outmatched and an idiot at this, so I need help. : (.! What can I try? What should I do? Should I just avoid GB?