FYI Swype Beta

djstnick

Member
Joined
Dec 3, 2010
Messages
54
Reaction score
0
For those of you wondering how to get the latest version of Swype on your Droid X, follow the instructions here:

Tutorial: Installing Beta Swype on Droid X

My question is how this will play with future releases of roms, and also how it will play with custom themes?

Currently running Rubix GB theme 1.9.5 and after installing swype 2.17 I lost the keyboard theme, as would be expected. Will installing a new theme screw up swype 2.17?
 

DebianDog

Rescue Squad
Rescue Squad
Joined
Jul 29, 2010
Messages
281
Reaction score
0
Location
Virginia
I am pretty sure if you have a custom ROM it is a bad idea to load it.
 

Backnblack

Premium Member
Premium Member
Joined
Nov 18, 2009
Messages
11,105
Reaction score
27
Current Phone Model
iPhone 7+ 256gb
As DebianDog has mentioned, Installing the Beta on a device with swype preloaded is not recommended.

Here is the Developers Site Swype | Text Input for Screens
As he mentions...
If your phone came pre-installed with Swype
DO NOT download this beta (it won't work)
 

v4npro

Member
Joined
Oct 17, 2010
Messages
93
Reaction score
0
Location
Maryland
I installed swype beta on gummyjar.. I followed those steps few weeks ago and haven't gotten a problem yet.
 
OP
D

djstnick

Member
Joined
Dec 3, 2010
Messages
54
Reaction score
0
As DebianDog has mentioned, Installing the Beta on a device with swype preloaded is not recommended.

Here is the Developers Site Swype | Text Input for Screens
As he mentions...
If your phone came pre-installed with Swype
DO NOT download this beta (it won't work)

Well, saying it won't work is false, I've had it running for about 24 hours now without any issues. Now granted, it doesn't work the way that it would for a phone without the pre-install, but it still works, and I have not experienced any glitches yet.

I think the reason that it is not recommended is because of the potential of modifying the wrong files, the software itself shouldn't be affected by the device using it, especially since the pre-install version is 1.64, and this version is 2.17, meaning it has everything 1.64 had, in addition to bug fixes and some new features, and larger keys.

1.64 is hardly a final version, I think the only reason it isn't a "beta" is because Motorola didn't want to admit to pre loading beta software onto its phones.
 

kheopsb

New Member
Joined
Mar 6, 2010
Messages
14
Reaction score
0
I installed the beta 24 hours ago and all seemed we'll, but today the swype input method process keeps crashing. I keep getting:
"swype.com.android.inputmethod stopped unexpectedly"
Does anyone else have the same thing happening?
I am running
Rooted 2.2.1. And swype beta 2.15.56.14870.
I installed it using the following process : http://forum.swype.com/showthread.php?1641-Tutorial-Installing-Beta-Swype-on-Droid-X

Sent from my DROIDX using DroidForums App
 
OP
D

djstnick

Member
Joined
Dec 3, 2010
Messages
54
Reaction score
0
I installed the beta 24 hours ago and all seemed we'll, but today the swype input method process keeps crashing. I keep getting:
"swype.com.android.inputmethod stopped unexpectedly"
Does anyone else have the same thing happening?
I am running
Rooted 2.2.1. And swype beta 2.15.56.14870.
I installed it using the following process : Tutorial: Installing Beta Swype on Droid X

Sent from my DROIDX using DroidForums App

Well, first of all you are using an outdated version, the current version is 2.17xx.

Second, I got that same issue with my initial install, but I think it had something to do with not following step 4)
"4. Delete (or move/rename) \data\dalvik-cache\system@app@Swype.apk@classes.dex"


If I were you I would recommend getting rid of the beta completely, and starting over from scratch with your stock android keyboard as the primary input device. Just follow the process again, perhaps you made a mistake following directions, or didn't restart when you should have, something dumb and seemingly unnecessary like that probably got overlooked.
 

kheopsb

New Member
Joined
Mar 6, 2010
Messages
14
Reaction score
0
Well, first of all you are using an outdated version, the current version is 2.17xx.

Second, I got that same issue with my initial install, but I think it had something to do with not following step 4)
"4. Delete (or move/rename) \data\dalvik-cache\system@app@Swype.apk@classes.dex"


If I were you I would recommend getting rid of the beta completely, and starting over from scratch with your stock android keyboard as the primary input device. Just follow the process again, perhaps you made a mistake following directions, or didn't restart when you should have, something dumb and seemingly unnecessary like that probably got overlooked.
great suggestion, I'll give it a try. I def did step 4 but may have forgotten the sequenced reboot.
BTW where'd you get 2.17? I just downloaded off the swype beta site, is there another place I should be looking?
 

Backnblack

Premium Member
Premium Member
Joined
Nov 18, 2009
Messages
11,105
Reaction score
27
Current Phone Model
iPhone 7+ 256gb
As DebianDog has mentioned, Installing the Beta on a device with swype preloaded is not recommended.

Here is the Developers Site Swype | Text Input for Screens
As he mentions...
If your phone came pre-installed with Swype
DO NOT download this beta (it won't work)

Well, saying it won't work is false, I've had it running for about 24 hours now without any issues. Now granted, it doesn't work the way that it would for a phone without the pre-install, but it still works, and I have not experienced any glitches yet.

I think the reason that it is not recommended is because of the potential of modifying the wrong files, the software itself shouldn't be affected by the device using it, especially since the pre-install version is 1.64, and this version is 2.17, meaning it has everything 1.64 had, in addition to bug fixes and some new features, and larger keys.

1.64 is hardly a final version, I think the only reason it isn't a "beta" is because Motorola didn't want to admit to pre loading beta software onto its phones.

To each his own, Just passing on what the Developer has posted.
 
OP
D

djstnick

Member
Joined
Dec 3, 2010
Messages
54
Reaction score
0
Well, first of all you are using an outdated version, the current version is 2.17xx.

Second, I got that same issue with my initial install, but I think it had something to do with not following step 4)
"4. Delete (or move/rename) \data\dalvik-cache\system@app@Swype.apk@classes.dex"


If I were you I would recommend getting rid of the beta completely, and starting over from scratch with your stock android keyboard as the primary input device. Just follow the process again, perhaps you made a mistake following directions, or didn't restart when you should have, something dumb and seemingly unnecessary like that probably got overlooked.
great suggestion, I'll give it a try. I def did step 4 but may have forgotten the sequenced reboot.
BTW where'd you get 2.17? I just downloaded off the swype beta site, is there another place I should be looking?

I downloaded the swypeinstaller.apk as i'm sure you did, and then went through the motions with that once I had the swype pre-install completely removed, and after a phone reboot to verify that the pre-install was indeed uninstalled.

Perhaps you are looking at the swype installer version, my swype installer version is version 1.1.16 (updated yesterday day maybe from 1.1.15)

Updates only come to swype when the swype installer is run, if a newer version exists it will install through that program I think.
 

kheopsb

New Member
Joined
Mar 6, 2010
Messages
14
Reaction score
0
Well, first of all you are using an outdated version, the current version is 2.17xx.

Second, I got that same issue with my initial install, but I think it had something to do with not following step 4)
"4. Delete (or move/rename) \data\dalvik-cache\system@app@Swype.apk@classes.dex"


If I were you I would recommend getting rid of the beta completely, and starting over from scratch with your stock android keyboard as the primary input device. Just follow the process again, perhaps you made a mistake following directions, or didn't restart when you should have, something dumb and seemingly unnecessary like that probably got overlooked.
great suggestion, I'll give it a try. I def did step 4 but may have forgotten the sequenced reboot.
BTW where'd you get 2.17? I just downloaded off the swype beta site, is there another place I should be looking?

I downloaded the swypeinstaller.apk as i'm sure you did, and then went through the motions with that once I had the swype pre-install completely removed, and after a phone reboot to verify that the pre-install was indeed uninstalled.

Perhaps you are looking at the swype installer version, my swype installer version is version 1.1.16 (updated yesterday day maybe from 1.1.15)

Updates only come to swype when the swype installer is run, if a newer version exists it will install through that program I think.
tried the uninstall, and redo but with the same result... I'll change the files bak to their original name and go through it again hoping it works this time. otherwise I'm pretty much screwed
 
Top