Field Force Manager (FFM) Issues


New Member
Mar 9, 2012
Reaction score
We have the Verizon Field Force Manager (FFM) app on our Droid Pro phones and seem to be having issues with it. The app takes GPS points and sends them back to the server so that we can track the different jobs that our inspectors do; how long they have been there; and the travel time and mileage it took to get there.

The problem is that some time FFM will lose track of the inspector and there are holes in the reports. When I look at a phone that is having this problem I discover that it can no longer communicate with the server. I can fix the problem by simply exiting the app and coming back in but there is no way for our inspectors to know if it is working or not to know to go in and exit the app.

I have tried to setup FFM to exit every night at 7:00 PM to force the app to shut down but this does not seem to work because the next morning when the app starts up it could stop working. I have tried to mess with the battery manager setting to make sure the OS is not shutting the app down because of idle time but this does not seem to work. The only solution I have found so far is to login into the FFM web portal every morning and check for phones that are not communicating with the server and call the owners to let them know.

I was wondering if there are any other Field Force Manager users out there, on an Android Phone or Not, that are having the same issues and if they found a solution?

I have been in contact with XORA, creators of Field Force Manager, and they are looking into it. I am doing some research on my own in the mean time.