Email solution?

I appreciate the info jlghertner, and I completely agree that everyone having a problem should by now be talking to Verizon as well as Google, but I know that people are talking to them already. Plus, this discussion is really only looking at the POP3 accounts which pull emails, not the Gmail accounts which Push emails to your phone from the Gmail servers since I am not having a problem so i can not test this on a phone that is having the problem.
 
Purgatory,

My wifi has been off for several days and it seems to work better with my POP3 email (verizon.net) I turned on my wifi and am still receiving email. It is hard to tell what works because the problem of not pushing email is intermittant. It may last for several days then not last 4 hours.
 
jlghertner, I would encourage you to try turning your Wi-Fi off for a whole week and see if it helps. Also jlghertner, I have had the email checking for a couple of days at a time, then just stop as well, so that is why i did my test of turning off my Wi-Fi, then rebooting phone, and then trying to keep pulling the POP3 emails for that entire week (lasted for 11 days actually until I turned on my Wi-Fi again and it last for about an hour then quit pulling the emails).

I would love to get more feedback from others trying the steps I have done and see if the results are different or the same. And of course, try and be as specific as possible, so we can see what the real issue might be.
 
Ok, almost 3 weeks and no pop3 problems--no wifi either.

One other thing: in k9 set "folders to display" to "all" for each account. There is a bug on google code about the default setting causing problems.

On a sorta related note, my gmail sync issues have ceased, perhaps due to no wifi. I also set gmail app > menu > settings > labels > inbox > sync all
...and I use Gmail Notifier from the market along with standard gmail notifications.
 
Thank you aminaked, I really appreciate you trying this so i know it is not just a fluke working for me.

I am using gmail notifier without using the standard gmail notifications, but i am getting all emails still as well. I do not have my folders getting all of my email as per what i said above.

This is disapointing because i do a lot over Wi-Fi with my droid (VNC, music control of my 200 Gig music collection, movies and shows, as well as transfering files wirelessly between phone and my NAS). I just haven't been doing this for the past 18 days again, and I will be turning on my Wi-Fi again because I need to start controlling everything again.
 
I don't have an issue getting my email using the standard or K9 programs I just don't get a notification anymore in the notification bar. All settings are correct that I can see, as it worked until I loaded a newer version of K9, now even going back to the original version of K9 that was working I still don't get notified.
 
I don't have an issue getting my email using the standard or K9 programs I just don't get a notification anymore in the notification bar. All settings are correct that I can see, as it worked until I loaded a newer version of K9, now even going back to the original version of K9 that was working I still don't get notified.

i don't have an issue getting email either, when i open the program up it will download my new email. However, this issue is being talked about because we are not getting notifications of new email. I would encourage you to read the first post and all the way through, you might find some helpful info for later
 
My email is actually already pulled and there when i open the program, I just don't know it's there. I can set K9 to show in the status bar when it is checking the email and that shows up there but never a notification icon that i actually got mail. Not a huge deal but something that pisses me off since it was working with K9 and the standard email program, I have no problems with my Gmail notifications.


I don't have an issue getting my email using the standard or K9 programs I just don't get a notification anymore in the notification bar. All settings are correct that I can see, as it worked until I loaded a newer version of K9, now even going back to the original version of K9 that was working I still don't get notified.

i don't have an issue getting email either, when i open the program up it will download my new email. However, this issue is being talked about because we are not getting notifications of new email. I would encourage you to read the first post and all the way through, you might find some helpful info for later
 
interesting, sounds like a different problem
 
Thank you aminaked, I really appreciate you trying this so i know it is not just a fluke working for me.

Right on, today marks 3 weeks that I haven't used wifi and 3 weeks with no email issues at all. I'm wondering if we could use wifi and turn it off when done. Would email break--is a reboot necessary?
 
I have had the problem of not getting emails since I first purchased the phone. I have only used Wi-Fi once since I purchased the phone a few months ago. It doesnt seem like the Wi-Fi is the problem.

Yesterday all my email accounts disapeared off my phone. I have no idea what happened to them. Maybe the program reset itself. When setting them all up I changed from POP to IMAP. So far today I have been receiving all my email as I should. Hopefully the problem has fixed itself. I will see what happens in the next week.
 
It doesnt seem like the Wi-Fi is the problem.

Wifi might not be the problem for everyone. It might not have anything to do with it, but it sure seems to make a difference for me.

mrygor, are you using a task killer? K9 or stock app? Any non-stock apps that run in the background? Do you have wifi off or just not set up to connect? Imap or pop?
 
I'm posting the following just in case others have run into the same problem and mistakenly believe that the email/gmail/k-9/etc apps on their phone is to blame for email anomalies.

Here's the situation. My wife gets her email via comcast.net. Her Outlook is set up to poll comcast.net every few minutes and download her email from the server to her desktop system. When I set up her K-9 email client linked to her comcast.net email I failed to take that into account.

As a result she was notified on her Droid that email had arrived but by the time she looked for it, the email had disappeared from the comcast server, having been downloaded to her Outlook client on her desktop.

There are several easy fixes for this situation including server-side forwarding of the email at comcast or forwarding of emails from her Outlook client when they're received. But I suspect that others may encounter what appear to be bizarre errors that result from this situation and may have trouble diagnosing it.
 
i dont get any notifications for email either and only time i will see my email is after i hit refresh. i have never used the wifi on my phone so i dont think that would be my problem. is there any other working email programs besides k9?
 
Back
Top