EAS Connection Error


New Member
Aug 17, 2010
Reaction score
I have had my Droid 2 for about 5 days. I've been using Corporate Sync for connection to EAS. Other than the annoying PIN issue (my Exchange is set to not require it, but I still have to put in a 4-digit pin everytime after 15 minutes of activity), the fact that the calendar doesn't sync back to Exchange, an odd Contacts thing where a lot of the Note field inside some contacts are missing, and no search in the corporate email (what!?), I really am liking this thing. Really!

I've been using Corporate Sync with Exchange since day 1. Other than the issues I noted above, it's been great. But, last night I started getting an error everytime Corporate Sync tries to connect. As far as I know, I didn't change anything. The notification says "ITNH account error" and when I drop the notification panel down, it says "ITNH Connection error". ITNH is what I named my account. I've pulled the battery. I've restarted the Exchange server, I've tried over 3G and Wi-Fi.

Update: I just tried removing and re-adding the account. That seems to have helped. I noticed once before when I did this that the contacts seem to double up, so I also went in and removed them after removing the account and before re-adding it. (Is that necessary?)

Any ideas why this would happen?