Droid RAZR Motocast not working


Nov 19, 2011
Reaction score
I have used Motocast a lot before, but now all of a sudden today my RAZR will not see my computer at all. My computer is up and running with Motocast running and says that it is online and everything but for some reason my phone will not see it. Im not sure what the problem is. Any help would be greatly appreciated since Moto's website says nothing.
I have been trying to get it to work since I got my Razr Maxx. It has been confusing because it work well on the laptop I run at work. My wife has an HP netbook and her Razr is able to connect with not problems. I have been able to upload picture after first set up but soon after started getting a message from my phone the computer was off line. Going to MyMotocast.com also showed my computer off line.

I went to Verizon who put me online with a Motocast tech.

Delete the Old
  • We uninstalled Motocast completely from the PC.
  • On the phone, we went into Setting > Apps > Motocast
  • Cleared the cache
  • Cleared the data
  • Deleted Motocast
Reload Motocast

The tech logged onto my laptop with log me in and started to install Motocast from their site.
We were running from a hotspot set up at the Verizon Store and it was painful.
I went home and continued on my network
  • Installed Motocast onto my laptop from the phone via USB cable.
  • By the time the down load and installation was complete the tech called and was able to reconnect via LogMeIn.
  • He did some check on the laptop and everything looked normal.
  • I re-installed Motocast from the PlayStore.
  • All worked well last night.
  • Could see the laptop from the phone and MyMotocast.
  • I have received a message that the connection is not secure.
  • I turned the firewall back on and have not see the message again.


I chose to listen to a podcast from my laptop still running at home. It works as advertised.
Still don't understand why it quite working. I was able to transfer files back and forth.

I have not changed my isp at home, Charter Communications, through a Buffalo G router.
I use Charters Security Suite.
I spent a lot of time with the suggestions given here and other forums. The problem was resolved by going to my Droid RAZR, selecting Apps, Motocast, and signing into Motocast (which was my GMail email and password). The upload immediately started. I think this happened after a Android Operating System upgrade last week (3-14-13).