Droid original Flash timing is off on camera, need assistance.


Jul 10, 2010
Reaction score
All of the sudden any picture that requires the flash on my non-rooted original Droid will either come out black, or VERY dark. When I take a picture that doesn't require the flash, everything is fine. I tried turning off the flash and taking the "flash required" pic again and it looked almost as it did through the viewfinder. I have rebooted the phone but that didn't seem to work.

Everything seems to function fine while taking the pic, but when it actually takes, it's just very dark. When I hit the button to take the pic, the flash will come on, it will focus, then the flash will flicker when it takes the pic, but that's when it goes wrong.

The last good "flash required" pic I took was 3 days ago on the 21st. I don't remember when the last update was, so I don't know if that's what could have caused it. Anyone know how to reset the camera app without resetting the phone?

EDIT: I just tried a different camera app from the Market and it's doing the same thing :(
Last edited: