Droid incoming calls


New Member
Oct 11, 2010
Reaction score
My first motorola droid started having some software issues so Verizon sent me another droid. I had ringdroid installed on my old droid so that I could customize songs to make them ringtones for my contacts. I received my replacement phone and downloaded ringdroid onto the droid they sent me and the sync installed all the songs I had on my old phone. The problem that I am having is this phone will only ring for about 5-10 secs and then it automatically sends my calls to voicemail and people think that I'm ignoring their calls and forwarding them to voicemail. Is there any way I can change this so that my phone rings the normal length of time before it sends my calls to voicemail? Thank You
I've never heard of a phone swap causing this but you can call 611 to have your ring length adjusted.
Make sure that you do not have checked to send all the incoming call to voicemail. I had a similar situation when I added different ringtones for certain contact they were all going to voicemail. select one of your contact that is going into voice mail then select menu/option incoming calls. I hope this helps
Does this happen when you select a stock ringtone too? Or does this only happen on the ones created by ringdroid? If it is just the ringdroid ones, try making new ones and see if it helps.
I do not have calls set up to go straight to voicemail. I will try selecting the standard ringtone on my phone to see if it rings for the normal length of time, but if it does the same thing I will call *611 and get them to lengthen the time on my ringer because I didn't know they could do this. Thanks and I will definitely post what I come up with.