Droid 4 in USB Debugging Mode - Can't Find Drivers

Jenny5

Member
Joined
Aug 26, 2010
Messages
33
Reaction score
0
I've read over a dozen threads and articles and can't seem to find a solution.
I have a brand spanking new Droid 4, not even activated yet. It has Android 4.1.2 installed on it (it was having this problem with ICS on it, too).
I'm trying to root it.
I've got it connected to a Win7 x64 system.
I've installed Motorola 5.9 drivers.
I've installed the Android SDK, and downloaded the Google USB and Google Web drivers with it.

When not in debugging mode, Windows recognizes the device just fine, all drivers are there.

When in debugging mode, there are two entries under Other Devices in Device Manager that don't have drivers installed.
It won't find the drivers when I tell it to look for them. I've tried pointing it to the drivers in the <sdk>\extras\google\usb_driver\ folder, and it finds nothing there.
Connected the droid to different USB ports.
I've tried with the Droid in both Mass Storage and MTP modes. Windows has been rebooted several times. The Droid has been rebooted a million times, while connected to the PC. I've tried every combination of connecting, rebooting, and toggling of debugging and USB modes. The Motorola Device Manager has not helped.
I have removed and re-added drivers several times.
I've spent too much time on this one thing that's supposed to be trivial, and I don't know what else to try.


Any help would be appreciated.
Thanks

Missing drivers for "XT894" and "Motorola Networking Device"
 

Attachments

  • massstoragemode.png
    massstoragemode.png
    8.1 KB · Views: 636
  • mtpmode.png
    mtpmode.png
    8.6 KB · Views: 600
  • otherdevices.png
    otherdevices.png
    1.9 KB · Views: 3,828
If I missed something or did something incorrectly, I can't figure out what it is. I sure would like to get this working. There are some things I want to do to really get this working right for me, and I need root to do it.
 
I am pretty sure I did that, as I stated in my first post. I installed the 5.9 drivers and the Motorola Device Manager that every page I found linked to.
Thank you.
 
I would connect phone, enable usb debugging, go to windows device manager, uninstall any device with a yellow triangle in front of it, disconnect phone, re install drivers, reboot pc, reconnect phone
 
I am pretty sure I did that, as I stated in my first post. I installed the 5.9 drivers and the Motorola Device Manager that every page I found linked to.
Thank you.

Yep, sorry...once I read that you installed the Google USB drivers that's all I focused on. Don't install the Google USB drivers, they overwrite the proper Motorola drivers.

As mentioned, uninstall the drivers and just install the Motorola ones.


Sent from my Nexus 10 using Tapatalk 2
 
I would connect phone, enable usb debugging, go to windows device manager, uninstall any device with a yellow triangle in front of it, disconnect phone, re install drivers, reboot pc, reconnect phone

Tried this repeatedly. Thank you.

Yep, sorry...once I read that you installed the Google USB drivers that's all I focused on. Don't install the Google USB drivers, they overwrite the proper Motorola drivers.

As mentioned, uninstall the drivers and just install the Motorola ones.

It didn't work with the motorola drivers before the google drivers were even installed.
Is there a way to extract just the motorola drivers or know where they get copied to? Thank you
 
I re-attempted this and still no luck. I made sure to uninstall the Motorola & Google drivers. Reinstalled just the Motorola drivers.
Does anyone have just the individual driver files they could upload, instead of a driver installation package?

So it has drivers for this phone so long as it's not in USB Debugging mode, but they are all from Microsoft, not Motorola, even though I've installed that Motorola package.
 
Don't think you ever posted which version of moto drivers or where you got them

when Droid 4 is connected in my computer there should be a
CD Drive named MotoCast open it and run MotoCastSetup.exe, it should download and install updated drivers

other option is install MOTOROLA DEVICE (Drivers) MANAGER

try
once you get a Device driver could not be installed message from Windows,... Start Motorola Driver Installer once again, and let it finish. Then...head to Device Manager, find the Unknown device, and in its properties' Driver tab click Update driver…. It should now install normally
may want to reboot pc

may want to watch [video=youtube;j_KPGUMzrjU]http://www.youtube.com/watch?v=j_KPGUMzrjU"]Device Drivers Install[/video]-by Tomsgt123
he shows how to use USBDeview for troubleshooting faulty USB device drivers

edit:with usb debugging on and in usb mass storage
the motorola devices listed in usbDeview, the device & driver name are in bold

0000.001d.0007.002.000.000.000.000.000 Mot Composite ADB Interface Vendor Specific Yes Yes No No 4/14/2013 8:52:14 PM 4/15/2013 4:10:17 PM 22b8 4372 2.16 ff 42 01 motandroidusb Mot ADB Interface Driver motoandroid.sys USB Motorola Mot Composite ADB Interface 1.2.13.0 USB\VID_22B8&PID_4372&MI_01\6&af40468&2&0001


Port_#0002.Hub_#0005 Motorola XT894 USB Device Unknown Yes Yes No No F:, G:, H:, J: 015451E602016009 4/14/2013 8:52:14 PM 4/15/2013 4:10:17 PM 22b8 4372 2.16 00 00 00 6&af40468&2 usbccgp Microsoft USB Generic Parent Driver usbccgp.sys USB (Standard USB Host Controller) 500 mA 2.00 USB Composite Device 6.1.7600.16788 USB\VID_22B8&PID_4372\015451E602016009


in mtp usb mode
Port_#0002.Hub_#0005 Motorola XT894 USB Device Unknown Yes Yes No No F:, G:, H:, J: 015451E602016009 4/14/2013 8:52:14 PM 4/15/2013 4:22:35 PM 22b8 4358 2.16 00 00 00 6&2a68990c&2 motccgp Motorola USB Composite Device Driver motccgp.sys USB Motorola 500 mA 2.00 Motorola USB Composite Device 3.3.0.0 USB\VID_22B8&PID_4358\015451E602016009

XT894 DROID4 Unknown Yes Yes No No 4/14/2013 8:52:14 PM 4/15/2013 4:22:36 PM 22b8 4358 2.16 00 00 00 WUDFRd WUDFRd.sys WPD motorola DROID4 6.1.7600.16385 USB\Vid_22b8&Pid_4358&Mi_00\6&2a68990c&2&0000

XT894 Motorola USB Networking Driver Communication Yes Yes No No 4/14/2013 8:52:14 PM 4/15/2013 4:22:36 PM 22b8 4358 2.16 02 0a 01 Motousbnet Motorola USB Networking Driver Service Motousbnet.sys Net Motorola Motorola USB Networking Driver 2.6.0.0 USB\Vid_22b8&Pid_4358&Mi_01\6&2a68990c&2&0001

XT894 Mot Composite ADB Interface Vendor Specific Yes Yes No No 4/14/2013 8:52:14 PM 4/15/2013 4:22:36 PM 22b8 4358 2.16 ff 42 01 motandroidusb Mot ADB Interface Driver motoandroid.sys USB Motorola Mot Composite ADB Interface 1.2.13.0 USB\Vid_22b8&Pid_4358&Mi_02\6&2a68990c&2&0002







look for drivers in
C:\Windows\System32\driversC:\Program Files\Common Files\Motorola Shared\Mobile Drivers\Drivers
C:\Program Files\Common Files\Motorola Shared\Mobile Drivers\Drivers
or
just open c drive and use search box in top right corner


edit 2:
copied all the drivers from C:\Program Files\Common Files\Motorola Shared\Mobile Drivers\Drivers
and uploaded to mediafire Droid 4 XT894 drivers win 7 64bit.rar
 
I installed the package you linked to, MotorolaDeviceManager_2.3.9.exe. And, as I mentioned above, I also tried Motorola_End_User_Driver_Installation_5.9.0_64bit.msi. But it came back with "Unable to install because a newer version of this product is already installed."

Here's some new information: I run Windows with a non-privileged account. I provide elevated credentials when needed. I used admin credentials to install the package. However, I realized the Motorola Device Manager was never popping up in the Systray. It never even prompted for elevated credentials. I realized this when I logged in with my admin account to retry the entire installation and it popped up. I let it check for new device drivers. But it failed to find any. I tried this with Debugging both on and off.
"There are no updates for your device at this time. Current Version: N/A"

I've been through everything in that video, including cleaning up drivers with USBDeview, and it hasn't resolved my issue.

Thanks
 

Attachments

  • noupdates.PNG
    noupdates.PNG
    11.6 KB · Views: 598
YOU ARE A SAINT.
:hail:
That worked. It installed those drivers. Haven't tried rooting it yet, but I'm pretty sure that's all that it needed.
Thank you thank you thank you thank you
 
great, post back here if rooting worked or not
 
Successfully rooted. I'm going to try to figure out how to get this back to ICS now.
Thanks again!
 
Back
Top