Complete reinstall... is that possible? How?

shlape

New Member
Joined
Nov 27, 2012
Messages
13
Reaction score
0
Location
Australia
I've come to the conclusion, after my Razr XT910 was offered an upgrade to ICS, the OS has become corrupt and needs a reinstall. I just don't know where to start.
I have tried clearing caches, rebooting, hardware rebooting etc... but the phone seems to be degrading.

I originally purchased it from Kogan (online) and found they had an Asia version of Android. My first suspicion is (if Asia specific) that it doesn't work all that great here in Australia. This is a long-shot but it is a possibility.

Google play appears corrupted as more and more apps come back with "Package file is invalid". I have reset the cache, tried several google play fix apps but no luck.
The camera and video camera intermittently works, other times no start... but worst of all, the phone reboots itself randomly, sometimes several times a day, without any user interaction. It just sits there and decides to reboot for no apparent reason. It has also done this during a phone call!

Forget about warranty; Kogan has a support team by name only. Their people are as useless and/or technologically illiterate.

I downloaded ICS via the 3G network and think it may have downloaded with errors, but still successfully upgraded.

Can anyone tell me:
1) where I can download ICS or Jellybean
2) where I can find step-by-step instructions to do a clean re-install


thanks.
 

dezymond

Tech Support Mod
Staff member
Premium Member
Joined
Nov 11, 2009
Messages
12,061
Reaction score
1,506
Location
Bay Area, California
Current Phone Model
Google Pixel
Have you tried a factory reset? Don't forget to backup whatever you want to keep first.
 
OP
S

shlape

New Member
Joined
Nov 27, 2012
Messages
13
Reaction score
0
Location
Australia
Then there was sadness...

After preparing everything properly and running the utility, my phone is now bricked.
The only screen I see on start up is

Code:
AP FastBoot Flash Mode (S) (Boot Failure)
0A.74
eMMC Info: Size 16G
To return to nromal mode - first press power key to power down
Device is LOCKED. Status Code: 0

Battery OK
OK to Program
Connect USB
Data Cable

Invalid CG OTV (CG: system): Invalid SP Data
Invalid CG HAB (CG: system, status: 0x004E)
Invalid CG OTV (CG: system)

The following is the output I got while using the utility's Fast Boot Restore (Option 1)

Code:
[*] Simple Razr Restore
[*] Windows Version
[*] Created by mattlgroff
[*]
[*] Before continuing, ensure your Razr is in the
[*] "AP Fastboot" mode and connected via USB.
[*]--- Also press the keys after the screen flashes back on when asked---
[*] IF YOUR PHONE SAYS STATUS 1 UNLOCKED EXIT NOW AND EMAIL ME
[*] YOU HAVE AN UNLOCKED BOOTLOADER! ! ! ! !
[*] [email]mattlgroff@gmail.com[/email]
[*]
Press any key to continue . . .
        sending 'mbm' (512 KB)... OKAY [  0.047s]
                 writing 'mbm'... OKAY [  0.562s]
     rebooting into bootloader... OKAY [  0.296s]
 Press any key AFTER the screen comes back on
Press any key to continue . . .
   sending 'mbmloader' (42 KB)... OKAY [  0.000s]
           writing 'mbmloader'... OKAY [  0.296s]
        sending 'mbm' (512 KB)... OKAY [  0.281s]
                 writing 'mbm'... OKAY [  0.484s]
     rebooting into bootloader... OKAY [  0.296s]
 Press any key AFTER the screen comes back on
Press any key to continue . . .
    sending 'devtree' (512 KB)... OKAY [  0.047s]
             writing 'devtree'... INFOPreflash validation failure
FAILED (remote: )
  sending 'system' (262144 KB)... OKAY [ 20.795s]
              writing 'system'... OKAY [ 11.014s]
  sending 'system' (262144 KB)... OKAY [ 20.764s]
              writing 'system'... OKAY [ 10.608s]
  sending 'system' (130816 KB)... OKAY [ 10.374s]
              writing 'system'... OKAY [  5.304s]
      sending 'boot' (8192 KB)... OKAY [  0.655s]
                writing 'boot'... INFOPreflash validation failure
FAILED (remote: )
  sending 'recovery' (9216 KB)... OKAY [  0.811s]
            writing 'recovery'... INFOPreflash validation failure
FAILED (remote: )
sending 'preinstall' (262144 KB)... OKAY [ 20.842s]
          writing 'preinstall'... INFOimage bigger than partition
FAILED (remote: )
    sending 'radio' (21900 KB)... OKAY [  1.747s]
               writing 'radio'... OKAY [  2.059s]
 It is recommened to wipe data, especially if you were on a custom rom.
 If you don't you will probably bootloop and have to wipe anyway...
 Press any key to Wipe the phone's data (NOT SDCARD(S)) or exit the utility.

Press any key to continue . . .
            erasing 'userdata'... OKAY [  0.936s]
               erasing 'cache'... OKAY [  0.952s]
    sending 'radio' (21900 KB)... OKAY [  1.732s]
               writing 'radio'... OKAY [  1.981s]
     rebooting into bootloader... OKAY [  0.296s]
 You are now on stock 6.16.211. Please boot normally by holding down power.

Please make a selection or hit ENTER to return:

what now?
 

FoxKat

Premium Member
Premium Member
Joined
Apr 2, 2010
Messages
14,655
Reaction score
4,720
Location
Pennsylvania
Current Phone Model
Droid Turbo 2 & Galaxy S7
Well, there's always RSD Lite and the ROM that can be downloaded and flashed directly.
 
OP
S

shlape

New Member
Joined
Nov 27, 2012
Messages
13
Reaction score
0
Location
Australia
working again but...

...and RSD Lite with ROM can be found at ..?

Never mind.

I found this group called the Eternity Project. I ran their v1.8 Flash program and the phone is ressurected. dancedroid

Unfortunately some of the old issues remain:
- Google Play: "Package file is invalid" on install
- Tethering doesn't work. I get connection with phone from PC but no internet. I've tried FoxFi but no luck there either.

any ideas?
 

ozorn

New Member
Joined
Jun 2, 2013
Messages
1
Reaction score
0
help

Never mind.

I found this group called the Eternity Project. I ran their v1.8 Flash program and the phone is ressurected. dancedroid

Unfortunately some of the old issues remain:
- Google Play: "Package file is invalid" on install
- Tethering doesn't work. I get connection with phone from PC but no internet. I've tried FoxFi but no luck there either.

any ideas?

could you send me the flash program? im in the same problem and i just can't get it, thanks
 
OP
S

shlape

New Member
Joined
Nov 27, 2012
Messages
13
Reaction score
0
Location
Australia
could you send me the flash program? im in the same problem and i just can't get it, thanks

Wow, this is an aged thread. :p

The website with the software is here.

As an update to all the dramas on my XT910, ie, 'Package file is invalid", camera working intermittently, random re-boots...
all seems to have been fixed with Jellybean. :icon_ lala:

I flashed an EU version of ICS (originally had an Asia version) and was eventually offered an upgrade to JB.
Having done so the phone works great (for now). It even tethers with my laptop, which I could never do before, ie. there would be a connection but I couldn't access anything online.

Hope this helps.
 
Last edited:
Top