Can't Upgrade to Latest version of software after trying to upgrade with Root


New Member
Apr 10, 2012
Reaction score
Hey everyone,

I am not familiar with all of the terms regarding rooting and sfb, so please try your best to dumb it down for me (thanks!).

I had my phone rooted by a friend who was able to install the drivers for z4root to work with superuser. Then, I received a notice to upgrade my Pro and I did so but it kept failing. I didn't realize that when you root you can't always upgrade.

Originally, I removed a bunch of bloatware like CityID and a few other things using Titanium Backup. When the install wouldn't complete for the update, I decided to do a factory reset.

By doing that, it removed Titanium backup and I think the update keeps failing because CityID is gone (but I can't be too sure).

I tried rerooting the phone and unrooting it again but the update still fails. I can't figure out how to sfb (if that's even possible without rooting) to get it back to day one with nothing on it but the regular crap bloatware it used to have.

Basically, I want to set it all the way back to square one since Verizon has backup assistant, I'm not afraid of losing any of my data. I don't know if I messed up my phone because I tried to upgrade while it was still rooted.

If anyone can please help me, I would be completely grateful!! I couldn't find any sfb files or RSDlite to get my phone back to square one.