Can't stay connected to my home wi-fi

nwuwildcats96

New Member
Joined
Aug 27, 2011
Messages
5
Reaction score
0
Hello,

Droid 2, not rooted here. I just set up a wi-fi router at home. I have been able to connect my laptop and a friend's laptop to it. I also have been able to get my Droid 2 and my friend's Droid 2 connected -- but they won't stay connected. They keep cycling, connected, not connected, connected, not connected. Am I missing something really obvious here? I have no problems connecting my Droid 2 to my friend's home wi-fi.

Thanks in advance.

Jason
 

lizard

Member
Joined
Nov 3, 2010
Messages
345
Reaction score
2
Location
Indiana
When my wi-fi cuts out on me at home its because i'm too far from the router. You used the word obvious:) If you haven't tried already, stay real close to the router and see if it changes for you. Just trying to help. I get poor reception in certain areas of my house, and I get better signal in my detached garage 20 feet from my house than I do in my living room one floor up from the router and 20 feet to the north. My router is in my basement by the way.
 

UrbanBounca

Rescue Squad
Staff member
Premium Member
Rescue Squad
Joined
Sep 25, 2010
Messages
2,749
Reaction score
207
Location
Virginia
I've had trouble connecting to N. My network is running G for that reason.

Sent from my DROID2 using Tapatalk
 

prime

Kernel Developer
Premium Member
Developer
Joined
Apr 26, 2010
Messages
1,940
Reaction score
71
Location
Florida
Website
github.com
What specific security method are you securing the router with? WEP, WPA2/TKIP, AES?

Also is the disconnecting coinciding with your screen going off?
 
Last edited:

mattman5000

Member
Joined
Oct 26, 2010
Messages
89
Reaction score
4
Location
Dallas, Texas
I was having same problem with an N router.

My original Netgear G router died. I replaced it with an N router. My phone would not stay connected to the N router. I tried all the suggestions that I read on the forums. Nothing helped. I had the same problem: connected, disconected, connected, etc. I finally took the router back the store and swapped it for a G router. It has worked perfect since then.
 
OP
nwuwildcats96

nwuwildcats96

New Member
Joined
Aug 27, 2011
Messages
5
Reaction score
0
Hey everyone, I got a solution. As has been mentioned, the problem was that my router is an N router, and Droid 2 Android 2.2 only recognizes G routers. However, I just upgraded to Android 2.3, and now my phone connects flawlessly to my wi-fi. I would suggest anyone who hasn't already, do a system update and get Android 2.3 Gingerbread.

Sent from my DROID2 using DroidForums
 

prime

Kernel Developer
Premium Member
Developer
Joined
Apr 26, 2010
Messages
1,940
Reaction score
71
Location
Florida
Website
github.com
An N based router does G also (unless set to N only), the issue is most likely the security method. Droids hate WPA2/AES, try WPA2/TKIP.

Sent from my Droid using Tapatalk
 

prtsmgr

Member
Joined
Sep 17, 2010
Messages
31
Reaction score
0
I have a Belkin N router and changing encryption did not help at all.
The only way my Droid 2 will stay connected is by assigning it a static IP.

On your phone:
1. In the advance settings, set wifi sleep policy to never.
2. unchecked auto IP
3. check static IP
4. Under IP address, put the Lan IP address and the last digit, pick an IP that is not in use. like.. 192.168.0.85
5. Gateway is your Lan IP (192.168.0.1)
6. Netmask: 255.255.255.0
7. DNS 1: Whatever it is on your router.
8. DNS 2: Whatever it is on your router.
9. If you are using tasker or any other auto profiles to turn on your wifi when you are at home based on your GPS location, don't do that. If you are walking in the middle of your house and lost the GPS connection, it will turn off your WIFI.
:)
 
Top