Can't set up my VPN - :( :( :(


New Member
May 3, 2010
Reaction score
I just got a HTC Incredible phone yesterday, and am trying to set my office VPN up on it. I have the Cisco VPN client set up on my laptop, and here are the settings from it:
Group Authentication
-- Name: AMC
-- Password:xxxxxxx
Transport: Enable Transport Tunneling
-- IPSec over UDP (NAT/PAT)
Those are really the only options there. Obviously when i connect it has a popup asking for my username and password, and once i enter those, i'm in.

Now on my Droid phone, there are 4 VPN options - PPTP VPN, L2TP VPN, L2TP/IPSEC PSK VPN, and L2TP/IPSEC CRT VPN. i'm pretty sure mine's the PSK (Pre-shared key), so i pick that, and these are the options i have:

VPN Server: (i set this as the host -
Set IPSec Pre-Shared key: (would this be... the password? i thought so, but why does the cisco client have 'name' too?)
Enable L2TP Secret (if checked, it has the option of entering the secret)
and that's it.

I've tried everything, but can't get it to work.

Any ideas? :(

Definately need to get this working in the next day or i'm going to have to return the phone - i need a phone that can establish a VPN to my office.

Note - i've tried connecting when connected to just the phone network, as well as when connected to a wireless network.


New Member
Dec 15, 2009
Reaction score

I to have been trying to get this set up on my Droid. We have a cisco VPN as well but cant seem to figure it out. let me know what you find out