Cannot switch back to unsafe, nor restore backup... :|


New Member
Feb 24, 2012
Reaction score
[SOLVED] Cannot switch back to unsafe, nor restore backup... :|

Safestrap 2.x + new roms = big DON'T. SBF helped restore the phone before it died.

Here's the story: I am dumb, I have learned it the hard way. I have tried loading one of the JB ROMs, I've seen something about "slot 1" and ignored it.
I have Safestrap 2.0, it doesn't have slots.

I did the full backup.
I did the formats.
I used the .zip.
The rom didn't boot, black screen.

I wanted to switch back to non-safe
"error while restoring /data" after 5+ (10?) minutes... not good, I thought.
I will restore the backup to the safe ROM, i thought, I will have my stuff back!
"error while restoring /data". ****.
Maybe not enough external sdcard (only one I could touch) space? I made some.
Still the same.
It stayed in the safe mode so I flashed a clean 4.0.4 ROM (deodexed stock), and got it working...

But I want my data back...
I tried switching back to unsafe after freeing some internal space, but still, "error while restoring /data"

Now I'm on a empty ROM-restore hybrid that has no apps. I see my SMS, and desktop icons (most of them), but it doesn't even have Play Store ("app not installed") so I'm kinda ****ed.

How to get my data back if neither unsafe mode copy nor unsafe mode backup restores?
Well first thing first, let's try and fix your safestrap. It's been a while since I used 2.0, but isn't there an option to do a quick switch between safe and non-safe without restoring data? If you manage to do that, you'll be back on your stock system but I'm guessing the data wouldn't be compatible, you'd need to wipe it to get it working again.

I'm guessing the reason you can't restore data is because roms utilized for safestrap 3.x handle data differently. Your internal sd should have been divided into slots.

My advice: get your stock system working again, uninstall and reinstall safestrap. Backup everything on your internal sd card you want to keep (your rom backup as well) then format it while running on your stock system. Then try and restore it using safestrap 2.0 if you don't want to start over on safestrap 3.x

For future reference if you install a rom and find you're missing the Play Store or the system didn't prompt you for a google sign in, it means you're missing gapps and you'll need to flash the appropriate gapps zip, depending on your rom. If you're not concerned about fixing your safestrap and your rom that you're on has your data but no gapps, flashing gapps should be all you need to do.

If all else fails and you cannot get your stock system working again, you'll most likely need to sbf back to the 4.0.4 ota. Having a working stock system is incredibly more important than restoring your data. You must also accept the possibility of not being able to restore your data at all. A mistake was made and now you have to pay the price.

Good luck and ask if you need help.

Sent from my XT894 using Tapatalk 2
I'm not quite sure how to sort out your current woes, but as a friendly heads up after you are up and running again, the CM10.x and up builds are only compatible with SS3.05 and up...maybe have been part of your original issue :frown:

SS3.05+ and slot-1 like you said...good luck!
As a quick reply to both of your messages: Yes, now I know that I should have upgrade to Safestrap 3.0 first. But I guess it should not cause my backup unrestorable? I'm trying to move between a 2.0-compatible ROM (deodexed stock) and stock, and both "restore backup" and "switch to unsafe" fail with the same message at the moment.
I guess I will try to experiment with a lot of backing up... And as soon as I get my unsafe with my data running, I will upgrade to Safestrap 3.0.

And about the quick switch option... yes, there is one, but I was unable to find a description on what it actually does.
Thanks guys,
any more input is welcome.
I basically laid out everything I know that you can do. Did you try any of it? Or was it still no dice?

Sent from my XT894 using Tapatalk 2
I'm guessing the reason you can't restore data is because roms utilized for safestrap 3.x handle data differently. Your internal sd should have been divided into slots.
I want to add here, that I have never ever successfully booted the Safestrap3.x JB ROM. The unsafe should be stock ROM, the backup of unsafe should have stock rom with my data and the switch should switch me to unsafe rom with my data. I was using the stock unsafe rom all the time, never really played with custom ROMs for more than 5 minutes yet.

The stock ROM is the one that I can't get to work.

Is trying to restore unsafe backup to a safe ROM The "unable to restore /data" message makes me stuck in safe mode, because it's an error whiel trying to get back to stock unsafe ROM. I would feel better if it worked and then I could upgrade safestrap and do everything like i should.
If I made the backup the normal way, and it completed successfully, what can prevent it from restoring correctly? The same goes to switching: i switched to safe with no issues, but I cannot switch back with the same error message (as far as I understand how Safestrap works, the backup from Backup&Restore is a separate backup from the unsafe image... but both have the same error message).

Because some things (stated above) aren't 100% clear for me yet, I am reluctant to experiment too quickly. I want to be cautious.

Worst case scenario is that I will only be able to get to my backed up data with WinRAR (it opens) and will forever be stuck on the safe (not so safe anymore) side, finding ways to upgrade Safestrap from there.

Edit: if I SBF (whatever the acronym stands for) to stock (The post with instructions says that I can't do it from ICS...) and *then* root, reinstall safestrap and try to restore my backup... what will happen?
I understand you didn't get the jb rom to run correctly and your back ups don't work. But that's because when you attempted to flash a 3.x rom, you most likely broke the way safestrap handles data.

As long as you have that backup you should be able to restore once you fix safestrap and be on your merry way. And I've given you a few options on how to do that.

In regards to sbf'ing, that should work. You're phone will be basically out of the box condition, but since you have that backup saved to your external sd card, you should be able to restore it once you've fixed safestrap.

I'm also willing to wager that the method of doing a quick swap where you try and go back to your stock system without restoring data, wiping it, and uninstalling and reinstalling safestrap would be faster. But it's your choice.

And you're correct to be confused on why a clean backup wouldn't restore and switching back to stock would be broken, because yes, they are independent of eachother. But truth be told I haven't heard of anyone doing what you've done on safestrap 2.0 before. So I'm making some very educated guesses here.

Sent from my XT894 using Tapatalk 2
But truth be told I haven't heard of anyone doing what you've done on safestrap 2.0 before.
Be a pioneer, they said, the world will be yours, they said ;-)

Thank you for the additional explanations/confirmations. That was basically what I needed (maybe except all of the unsure parts). I will try one of your suggestions and see how it turns out as soon as I'll have enough time with piece of mind. Thanks, I will post an update if anything changes.

I'm curious if you solved your problem? Cause I think I just managed to do exactly the same mistake. I've spent this whole afternoon/early night reading, reading and reading before trying to install the latest PACman build (V06). So, here's what happened:

I have a XT910 gsm. I'm from Sweden so 4.0.4 is all I've got the official way. I found safe strap 2.1.1 (not 100% on the exact version number though).
I rooted, no problem.
Installed superuser, Busybox and everything, no problem.
Installed safe strap and made a Nandroid backup, no problem.

Since all this worked, I thought it was "all clear" to experiment. I have my backup, right?

So I follow all the instructions switching to safe mode, wiping cache, dalvik-cache, formatting system and installs PACman V06. Clear cache, reboot, install Gapps. Clear cache and reboots.

Obviously, the ROM black screens, so I go into safe strap to switch to the un-safe stock system. Problem is it says "error" when trying to load /data, and I get stuck in the safe mode. I've read something about not trying to restore a "un-safe" backup when in "safe" mode, so I haven't tried that.

Since I obviously didn't learn enough beforehand, I now humbly ask for assistance of how to clear up this mess. If I could get guidance to a point where I can get the phone working with my stock backup as the "un-safe" system I would be really really thankful. And from then do my homework more thorougly before the next try :)

I'm going to sleep or now (02:30 am here) so I won't reply in 15 hours until I get home from work,
In regards to sbf'ing, that should work. You're phone will be basically out of the box condition
We all hate those problem threads that look like the person posting the original post just died in the middle and we never know if he or she solved it.

Therefore I'd like to confirm: that worked. At some point in time, much later than you wrote this, since I didn't have the guts, but also a long time ago, I did read more about how to SBF (whatever it means, you never really get to know the terms people use as acronyms on these forums ;P) and I did recover my phone. And, also, use the stock ROM since then (except that I can't stand how slow it got anymore).
My phone is "recovered" then and I never ever installed Safestrap again. Yet. ; )