Can not connect to Market Place


New Member
Mar 3, 2011
Reaction score
The other day My phone died completely so I did a hard reset.

Everything fine but for some reason I can not access my google/market place.

To get to my apps, I have to sign in through the market using my google account, Using the one I always try I can an error and also get it when I try to create a new one.

"Can't establish a reliable data connection to the server." Please contact your date provider.

Called T-mobile (UK) they have no idea, Tried some other forums which gave me an .apk but this doesnt work as It doesnt have a T-mobile UK setting... This is what I was given
Market Enabler available for download at

Download Market Enabler, copy to device, tap to install
Open ME, select Settings List
Tap and hold on a carrier
select "fake this provider now" > allow"

This doesnt work as When you go to settings list It doesnt show UK carriers (Mine is T-mobile) and the ones there dont work.

Any help appriciated.


Called T-Mobile who helped sort the APN settings this did not work.

Tried the following..... Go to settings->applications ->manage applications -> market and select delete updates.

Didnt work due to There is no apps in there due to the fact I cant install any. Market isnt in as it is already built into the phone I guess

This was mentioned...
'restart the phone without the SIM card, and connect to some WiFi network,
so you can login to your Google Account.
It will log you into the account, and then you can put the SIM card back.

Didnt work....

I even got an .apk for market place and tried reinstalling but when I tried to reinstall it it told me PARSE ERROR

Id love to get this fixed without re-flashing help would be great.


Feb 28, 2011
Reaction score
Springdale Pennsylvania
Current Phone Model
Samsung S7
I'm in the US had a similar issue not being able to connect to the Market, did a battery pull while the phone was on, restarted the phone, re started the market and got an error msg over and over again. Tried it this morning and had to use the "retry" option and I finally connected.. Dont know what was going on but its working just fine now..

Good luck