Camera wont work with Liberty


New Member
Jan 23, 2011
Reaction score
After flashing Liberty 1.0 I seem to lose my camera functionality.
I have tried all the normal suggestions, such as fixing permissions and zip aligning apk's.
When ever I try to open my camera I hear the camera clicking and then It says "cannot open camera, please try again later."
I also cannot open my camcorder.
I really like this rom, but I need camera to work. Any suggestions?

After re-flashing to my backup (stock), camera works fine. I then re flash Liberty and the camera will not work as soon as i get loaded up.
Camera Error
Cannot connect to camera.

Ive tried d/ling and installing the other cameras from the liberty add-ons, but neither the blur or the aosp will work.

Just for curiosity, I installed GummyJar to see how this would affect my camera.
I did a full restore to stock and then rom'd with gummyjar.
Camer behaves the same way.... cant connect.

This is driving me insane. Can I just get another camera.apk and use that? what would explain my camera will not function with these roms?

any help will be greatly appreciated
No one has experience with this? I am admittedly new to this but I cant understand why the camera will not work with the Liberty(or gummyjar) rom.

I need to understand how this process works. Where are the .apk's stored on the phone? can you write new ones to this location or do you need to put them in the rom and then re-flash the whole thing?

What tool do you use to see these files? I am not able to explore to the system/apps folder. Where is it? Why cant I find it? Do I need some type of terminal to do this?

I understand that these files are stored in the rom zip file, but when the phone is flashed with the rom, where are these files stored/how do i get to them.

I want to try and overwrite the camera.apk file on the phone.

I'm sorry I thott I replied to this....I had the same up libertytool box app after install addons and install either blur or aosp camera that should work

Sent from my DROID2 using DroidForums App
I did that.
No luck with either.
I dont know what is with my device but i have reinstalled liberty numerous times and I still get no camera functionality.

Thanks for the advice, though.
Hmph that worked for me man...sorry...what you could do is locate the build.prop file and check the MP if its 8 change it to 5

Sent from my DROID2 using DroidForums App
Here's a random idea but it helped with my camera acting wild. Go to settings>liberty settings and uncheck the restore apps option. Than go to toolbox redownload camera of your choice and see how that works. Helped me. Also go to wherever the toolbox downloads stuff, delete the downloaded camera app and try to redownload and install again. Hope something here helps.

Sent from my DROID2 using DroidForums App
Im almost too embarrased to admit this but........... here goes.
I just realized that I DLed from the DX link (I'm now assuming this is for droidx?)
This gave me a file :icon_eek:
I'm thinking I need the File (for droid2?)
Im applying this now, hopefully it fixes my camera issues.
That did it! Camera is up and running!!!
Just figured I would post this incase someone made the same mistake I did. I guess I just assumed that because we were in the D2 forum, all the links would be for the D2, even though there is a DX and a D2 link

Thanks to all for your replies, however.
I guess be glad that's all that happened lol. One time I formatted the system and fat fingered the reboot now button. So stupid things happen to everyone lol.

Sent from my DROID2 using DroidForums App