Anyone else having issues with long press fuctions on the home/search buttons?


Nov 22, 2009
Reaction score
Colorado, USA
I'm talking about the four buttons across the bottom of the screen when in portrait mode. These can be long pressed for other options. For instance the home button when long pressed presents a program switcher screen (which has gotten awful for me since the 2.0.1 update... never has Gmail or browser which are the two most common ones I need to switch to) and the Search button also gives some other options. I noticed a while back that sometimes my home button wouldn't respond to a long press. I would get the initial vibrate from the single press but it wouldn't register the long press with a 2nd vibrate and bringing up the program changing screen. This is quite frustrating as it then takes several key presses to get to the program I'm trying to change to. I also recently installed an app called jkAppSwitch which works like the long press home key program switcher with more customization. Since the standard switcher no longer shows my browser or Gmail I figured this was a better solution since the other wasn't adjustable. For the first day or so this worked perfectly, long press on search and then there were all of my open programs. Then, recently, it quit working entirely just like the Home button had done for long presses. Short presses still work and long presses give a short press result however no long press. I tried power cycles to no avail. This is quite frustrating and if the stock changer were to work the way it had when I first got the phone I wouldn't have the 2nd problem but it does not and so I'm left with two problems to the same issue.

Ideas? Thoughts?
I have home ++ and I'm not sure if its just for that or it works on the regular version, if you hold down the menu button there is screen switch, maybe you could just switch to ur home screen or click a screen that has the app ur looking for on it?? My home button usually works pretty well and I'm able to bring up my frequently used apps... dunno if this helps but its s temporary fix to a problem that can hoepfully get fixed...

** nevermind... only works from the home screen not an app... sorry :/
A correction for the OP, the program switcher thing (from holding home) allows you to choose your last 6(?) used programs.
A correction for the OP, the program switcher thing (from holding home) allows you to choose your last 6(?) used programs.

It's supposed to but the key is that, for whatever reason, it's no longer the previous six. I use Gmail about every 2nd or 3rd app as well as the browser so both of these should be in this short list every time. This is the way it was when I first got the phone for about a month or so. Then it seemed to not be this way and I believe I started noticing it around the time of the 2.0.1 update so I'm not sure if it has anything to do with this but is likely. The long press has been intermittent for me for weeks now and after about a day of using jkAppSwitch by long pressing the Search key the long press of the Search key has gone away completely for some unknown reason. Nothing seems to be bringing it back and this could be used for Handcent, jkAppSwitch or even the Voice search option. Now... nothing.

So I basically have two problems and both are related in they they limit my program switching which I use quite frequently normally. If the built in switcher really would display the last six the way that it used to then I wouldn't need the jkAppSwitch app. It doesn't so I installed this and it worked fine and filled that gap for a brief period and now... no long press on the Search key. To be honest I don't know if this one just started because I wasn't aware that one could long press the Search key until I installed jkAppSwitch. All I know is it worked flawlessly for about 24hrs or so and now nothing.

I used to have PandaHome and a few other apps that I uninstalled to try to get my Droid back to 'out of the box' reliability and quickness but it doesn't seem to have affected this particular issue one way or another.

Kind of frustrating.
Quick update: I just uninstalled jkAppSwitch once again, rebooted and the long press on both my Home and Search buttons has returned. I installed jkAppSwitch fresh and will continue to test it to see if it remains stable. If this happens again though I'll uninstall until they fix the issue... if there even is one. Still odd about the actual content of the programs listed in my native program switcher which is accessed with the long press of the Home key. Weird that it worked fine for so long and now it appears to be random programs and not the last six used as I had grown accustomed to. Not sure what could have caused that.
Well damn, now it seems I've been struck with this. I had the last 6 apps I used listed in the pop-up bubble, made a phone call (this was not one of the 6 last used apps though) and after I hung up, I long-pressed the Home button and the only app listed was...the phone. I can't recreate the issue either.

The ONLY 3rd-party apps I have installed atm are:

Astro File Manager
ShapeWriter Keyboard

I had done a hard-reset about a week ago, installed the above 3 apps and that's it. I'll report back if I figure out what caused it or if it happens again.
So after uninstalling jkAppSwitch I was able to recreate the same problem so it's not jkAppSwitch that's causing the issue as I previously suspected. Also, it seems that at times that the long press isn't responding on the Search it still works on the Home so it's not an across the board long press issue. Weird.