Another Droid Razr problem - Tried everything


Apr 30, 2010
Reaction score
I got a Droid Razr from a friend who tried to do a "battery pull" to fix it when it was locked up or something. Her battery pull was exactly that. She ripped it right out tearing the ribbon cable that connects it. She says it worked fine before that, other than the "lock up". So I picked up a new battery from ebay and put it in.

It still didn't start up, initially. The first thing I did was plug the phone into the computer; that gave me the white led. Next, I tried the wall outlet adapter; that got me to the Motorola logo and the battery symbol that showed 5% charged and 100% charged, and nothing else. The phone wouldn't turn on.

After reading as much as I could find today, I found out about the factory programming cable that adds power to pin 4. I made one and then things changed up a little. Now, with the new cable, I can only get the phone to power on when it's connected to a computer and it does nothing when connected to the wall adapter. When connected to the computer, however, the phone boots all the way up but it won't charge. When I disconnect it, it turns off. I've left it connected to the computer or wall outlet in various states of operation (os fully loaded, boot menu, and off) all day.

While the phone is connected to the computer and booted up, when I go to battery stats, it says it's 5% charged and that it's draining.

I also decided to try connecting negative and positive leads directly to the battery terminals from the USB wall adapter. When I do that, the phone boots up and the battery stats says it's at 90% charge and draining.

I've tried 3 different wall adapters. One 500 mah, one 750 mah, and one 1000 mah. Same results on all of them.

I also inspected the inside of the phone for damage from the "battery pull" but there does not appear to be any.

Any ideas?
It's quite possible that when she "ripped" the battery out she may have shorted the leads and damaged the circuitry that recognizes the battery as a source of power. From what you've described the battery is potentially fully charged, or at worst perhaps 90%, so that's obviously not the problem. The USB cable supplies power to the phone in two different ways, as you've discovered.

1) The standard method of power through the USB port is to send charging current to the charging circuitry. The charging circuitry is essentially a completely separate custom purpose computer. It's not dependent on the phone's computer, and its entire purpose is;

  • to monitor the battery's health,
  • State of Charge levels,
  • decide when and if to charge,
  • regulate the amount of current going to it while charging,
  • allow power to pass from the battery through to the phone,
  • or remain off and run on battery power only.

Since the charging circuitry controls all power to and from the battery (and to the phone), it's critical to the phone's ability to boot. If it decides to run on battery power only, or while charging allows power to go TO the battery to charge, power over and above what the battery draws (if charging), is routed to the phone for powering the phone itself. If the battery is damaged, or if the circuitry that charges the battery is damaged, the phone won't receive power since the charging circuitry won't allow it to pass through.

2) The alternate USB power method using a Factory Programming Cable (which supplies power directly to pin 4 as you learned), bypasses the charging circuitry altogether and sends power directly to the phone. If a battery is present and in good health, the Factory Programming Cable will also send a small residual amount of current to the battery - a trickle charge, so this is why it's useful to revive a deeply discharged battery. This is why the phone will boot and operate normally while on that cable, even if there is no battery, but will shut down immediately if removed - even if there's a battery present but the charging circuitry or battery are not functioning normally. This is also why the phone doesn't go into the Charge Only mode when connected to the Factory Programming Cable, since it doesn't send ANY power to the charging circuitry.

So if the battery is good, as it appears, and if it has even a partial charge, and yet the phone won't boot with the battery connected to the two terminals properly, then this points to a charging circuity failure. Since all batteries are shipped with a charge of approximately 40% to preserve their ability to be charged and prevent self-discharge to zero and shut down permanently, we know that the battery had at least enough power to boot the phone successfully right from the package.

I hope that this explanation is helpful in your troubleshooting, and I hope I've given you some information that can help you to further test my theory and possibly isolate the problem. Finally, I hope I'm wrong and there's a simpler explanation for your troubles that won't end badly, but I suspect the damage is done, as they say. :frown:
I was afraid that may be the case. Thanks for all the info, that really helps.

I Might try finding one with a broken screen or something and try to swap out some parts to get it going. If I can get one cheap enough.