Android Tablet, Google Play Services won't update

inoculah

New Member
Joined
Aug 5, 2018
Messages
2
Reaction score
0
I have been using this tablet for over a year and I just recently tried transferring some books to it from my pc. well as I decided to just download them from the site i bought em on. my google play services randomly decided to I'd say crash. it won't update. it gives an error code and i have tried clearing the cache and date with no luck. its keeping me from using the app store and chrome to search anything. Android version 6.0.1 and the Google play services version is 8.7.03
Also for some reason my tablet wont connect usb to my pc for file transfer but i can live without that.
 
Huh. Not a tablet I'm familiar with, sorry to say. In my experience clearing app caches often helps; otherwise try uninstalling and reinstalling the apps in question. Sorry I don't have better advice.
 
If the above advice doesn't work there is always the nuclear option, a factory reset. My wife used to have a digiland tablet. They can be problematic.
 
Back
Top