Amon ra's recovery image issue


New Member
Jun 3, 2010
Reaction score
Saint Cloud MN
I just got my Droid Eris about a month ago. I have never owned a smartphone before, but being the curious person I am, I began to look into the process of rooting my phone so I could flash in some custom roms. So

I finally sat down today to go through the process of rooting my phone using the tutorial I found here: How To: Load a Custom ROM on the HTC Droid Eris (Updated ? 04.08.2010) | TheUnlockr

So, I finally get down to the last shell command, where I'm guessing it's flashing the amon's recovery image to the recovery partition:

adb shell flash_image recovery /sdcard/recovery-ra-eris.img

And I get this long string of errors
mtd write error at block (00x00000(or whatever other numbers))
Error writing recovery no space left on device

I have something in the order of 500mb left on my sd card, I really didn't think I would need more. Has anyone else run into this?
i got that too and i just let it site and go through all of its junk till it gave me the c/ AndroidSDK/tools/ prompt agien. and i typed adb shell remount in the comand prompt and it said mount succeed and i tryed the command agien and it worked.

hopefully that helps
Well, I got the whole thing worked out. I just restarted my phone, and it worked. I have another problem now though. I flashed to the Evil Eris v3.0 rom, and now, the adb drivers stopped working on my computer. When I plug my phone in, the found new hardware wizard comes up. When I go through it, and tell it to look for the drivers in the android sdk dir, it comes up with nothing.
ok uninstall you htc drivers and download HTC sync for the website cause that installs new usb drivers for HTC thats how it worked for me