Super weird sd card bug not allowing phone to boot.

Discussion in 'Android Tech Support' started by nerdkill, Jul 30, 2010.

  1. nerdkill

    nerdkill Member

    Joined:
    Dec 26, 2009
    Messages:
    542
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I had a really weird thing happen to me. I was running saphire froyo rom and my phone started acting crazy, getting supper hot, freezing all of the time, etc. This was happening over about two days. All of a sudden i looked at my phone and it was black with the soft keys lit. Tried to re-boot and it would start, but then it would go to a black screen. I could tell it was on, the screen was on, but just black. Sometimes when I would hit the power button the soft keys would light, but that was all I could get out of it. When i think back the last thing i remember doing was running fix permissions in rom manager (maybe that had something to do with it?). Anyways, after trying a bunch of different things (wipe data, nandroid back-up, cache) i figured out it was actually my sd card that was causing the problems. I noticed the problem would happen on boot up when it would start reading my sd card. Installed a new one and the problem went away.

    Now, i starting erasing files one by one using my computer and re-trying my sd card. Never got rid of the problem. Then i tried to erase all files and a few were unable to be erased. Tried the sd card again. Same problem. then inserted my sd card into my computer again and it gave me a message saying there might be a problem with my sd card and do i want to try and fix it automatically. Said yes, then i was able to erase all of the files on the sd card. One of the files i couldn't erase was x-scope. Is it possible i got a virus or something? It's a bummer because now I've lost everything on the sd card, but i'm happy that I was able to save my sd card. Any ideas?
     
  2. mx371

    mx371 New Member

    Joined:
    Apr 29, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Not sure on causes but I'm having similar problems with my gf's phone. Had her running BB 0.4 with Black Glass running flawlessly. Tried to make a backup to switch themes yesterday and the recovery said it couldn't mount the sd card. Been having tons of problems since; it's been super laggy and I still can't properly mount the sd card. Will be keeping an eye on this thread and going to try removing stuff from the sd card.
     
Search tags for this page

sd card causes phone to not boot