Softkey LEDs stay on full while in dock/night mode

Discussion in 'Droid 2 Tech Issues' started by kenryan, Sep 4, 2011.

  1. kenryan

    kenryan New Member

    Joined:
    Nov 10, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I upgraded to GB a couple days ago, it's been a great improvement in a lot of ways but it seems one thing is not working as well as it used to. I keep my multimedia dock by my bed, to use my phone as an alarm clock. The screen dims properly when I dock it, but since the upgrade the LED backlights on the four softkeys no longer dim. They stay on full-bright and light up half my bedroom.

    Up until this evening it was a stock GB, I just rooted it but haven't done anything but run a backup and run adfree. I do have screen brightness set to minimum and automatic while docked. My phone is a Droid 2 (not Global or R2D2).

    Any thoughts on what might be wrong?

    Thanks in advance...
     
  2. Malvado

    Malvado DF News Team/Mod
    Premium Member

    Joined:
    Nov 7, 2009
    Messages:
    1,991
    Likes Received:
    15
    Trophy Points:
    103
    Ratings:
    +15
    They stay on all the time. I've used it on stock droid 2 and droid 3 and as far as I know, they never go off.

    Sent from my DROID 3 directly to YOU!
     
  3. kenryan

    kenryan New Member

    Joined:
    Nov 10, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Erm, I am quite sure it used to dim the softkey LEDs...
     
  4. Ellyenne

    Ellyenne New Member

    Joined:
    Sep 10, 2011
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    1
    Ratings:
    +1
    Kenryan: you are not dreaming. I'm having the same problem. I've had to resort to draping a piece of paper over the 4 softkeys. Sometimes they go out, mostly they do not. It has something to do with the light sensor. This is yet another problem that started with Gingerbread that was never a problem with Froyo. I really do not want to root my phone, and I don't think it is something that a root will fix! It's another Gingerbread incompatibility with the hardware (see my post about the slide-out keyboard's new problems).
     
  5. Malvado

    Malvado DF News Team/Mod
    Premium Member

    Joined:
    Nov 7, 2009
    Messages:
    1,991
    Likes Received:
    15
    Trophy Points:
    103
    Ratings:
    +15
    Hmm I have a d3 and it wont ...I wonder....lol

    Sent from my DROID 3 directly to YOU!
     
  6. mikedyk43

    mikedyk43 Member

    Joined:
    Sep 10, 2011
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    This problem also happened to me when I updated my OG Droid to GB. The only solution I found was installing a 3rd party clock app. I am using Alarm Clock Plus(free) which looks identical to the stock clock, however you can customize fonts and sizes, but most importantly it has a "hardware dim" setting that does turn off the soft key lights.
     
  7. TPX00

    TPX00 Member

    Joined:
    Jun 22, 2011
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Cave Creek, AZ
    Ratings:
    +0
    I just replaced the LCD in a D2 and was having the same prob as soon as I rooted it. But it was all the time and killing the battery on my friends phone. then I read somewhere that if you are rooted you can download from the market an app that overrides it. It worked for this phone. D2 GB 2.3.5 rooted CM7 running ADW EX. its called LEDs Hack (Root Only) give it a whirl! Maybe you'll get lucky!
     
Search tags for this page

alarm clock plus hardware dim

,

dock clock soft keys wont dim

,
droid dock clock buttons
,

droid x dock clock on off

,
droid2global soft key lights wont turn off
,
how to keep the softkey led on for longer
,
how to turn off droid light cradle mode
,
night mode doesnt work on softkeys
,
soft keys light dock clock
,
softkeya wont dim