WiFi not working on Droid X

hammerhead13

Gold Member
Joined
Jan 25, 2010
Messages
1,360
Reaction score
582
Location
Florida
Current Phone Model
Samsung Galaxy Note10+ 5G
I lost my WiFi on my Droid X. I did the last OTA Update and I am now using System Version: 4.5.605.MB810.Verizon.en.US. I had rooted it prior to the update and had no problems. My wireless shows I am connected to my Router and I have an IP Address but I can not use Internet on my WiFi. Anyone else having this problem?
 

leftspin

Active Member
Joined
Jul 27, 2011
Messages
1,128
Reaction score
8
Location
New Jersey
I lost my WiFi on my Droid X. I did the last OTA Update and I am now using System Version: 4.5.605.MB810.Verizon.en.US. I had rooted it prior to the update and had no problems. My wireless shows I am connected to my Router and I have an IP Address but I can not use Internet on my WiFi. Anyone else having this problem?

you've tried rebooting and battery pulls and all that?
 

tjk629

Silver Member
Joined
Jan 5, 2010
Messages
3,038
Reaction score
65
Current Phone Model
NEXUS 6
Dad's X does this. Tried factory resetting the router (an old trick for my OG) and it didn't seem to do anything.

Have you fixed yours?
 

JRParsons

Active Member
Joined
May 19, 2011
Messages
486
Reaction score
43
Location
Mass.
Interference can sometimes play a part in this. The phone will connect but it will "wait its turn" to send and receive data, check if it will connect and transfer over a different wifi network. (starbucks, etc.) If not then you may be stuck with the hard reset, I assume you already deleted and readded the wifi network on the phone.
Interference can come from a microwave, cordless phone, (worse yet, a neighbor's cordless phone) or in my case it is from my Samsung wireless surround sound. Took me a long time to figure it out, but as soon as I turned off the surround sound my laptop, thunderbolt and PS3 all connected and worked flawlessly. Prior to figuring it out they would all show connected with great signal strength, but would not work. (this really sucks on the PS3 where I would like surround sound during Black Ops sessions, but can't have both)
I have been told that a duel band router may fix the problem. But haven't tried it yet.
Good luck.
 

tjk629

Silver Member
Joined
Jan 5, 2010
Messages
3,038
Reaction score
65
Current Phone Model
NEXUS 6
I was able to fix the issue. Seems like GB blur phones don't like AES security. They'd much rather have TKIP. So set the router to AES &TKIP. As some devices in the house don't like TKIP.

Talk about picky!

Sent from my DROID BIONIC using DroidForums
 
Top