Very Strange Boot-Loop Issues On Bricked Incredible, Advice Welcome


New Member
Sep 9, 2010
Reaction score
So I have this DInc that I purchased from someone because of the bootloop issue that it was having. It boots into HBOOT just fine. However none of the options like recovery or reset manage to fix the phone.

Whats weird is that RUU files renamed to on a FAT32 card flash perfectly. No issues with anything. That still doesnt get the phone to boot. It goes from HTC Incredible> HTC simply brilliant?> boot animation> back to HTC Simply brilliant. Boot loop. Tried both 2.1 and 2.2 RUUs.

Flashing files like ClockworkMod renamed to PB31IMG works, but i still cannot get into a custom recovery. It seems like it doesn't do anything.

Booting to recovery goes to the red triangle, i press volume^+power and get to the android recovery menu. The weird thing is that it gives an error like cant mount E:/dev/blk0p2/, something along those lines in yellow text below. Corrupt/missing internal partitions?

Edit- Android Dubugging Bridge adb, does seem the phone when I am in the recovery screen however it is offline so I can't do much unless someone knows how to make it online while in the recovery

Probably a hardware problem if ruu flashes but still doesn't fix the bootloop?

Anyone need an AMOLED screen/digitizer? :icon_eek:
Last edited: