SGS3 OTG Cable Issues


New Member
Aug 4, 2012
Reaction score
Hey guys at! So in the past, I was able to use my ancient ancient external hard drive on my S3 through an OTG cable (female usb to male micro usb). This hard drive was like 156 GB, and had to be plugged in to an outlet for power. So I recently made the switch to a brand new Toshiba 1TB drive. However, I can no longer get it recognized on my S3. My S3 is running 4.1.2, rooted, has stickmount and paragon apps, and still to no avail. My HDD was originally formatted in NTFS, but after the first failure, it was reformatted to exFAT. When I plug the HDD in at first, I get a quick notification of "USB connector connected" but nothing else. I've seen videos of other people on the internet easily plug in a 1TB HDD and access files on it, eliminating the idea that it is a problem powering the hard drive. Has anyone else had trouble with this?

EDIT: I just tried plugging the the HDD with the OTG cable into a family member's stock S4, and it worked perfectly.

Last edited: