Post-Root swype problem - need help!


New Member
Mar 24, 2011
Reaction score
First off, this forum has been an invaluable source of info for the rooting and ROM installation procedures, so a big THANKS to everyone!

Second, I'm using a Droid X, which has now been rooted (via Z4 1.3.0), and with the help of Bootstrapper, have Rubix Focused 2.0.1 installed.

For the most part things are good; the phone is fast and clean. However, as implicated in the thread title, I'm having a problem with swype. It just will NOT work! Initially upon install, the option to activate swype was not present (in Menu->Settings->Language&Keyboard), nor was the option to allow an uninstall from the app manager. I tried to run the installer (for the same version that was "running") from Astro, and it wouldn't uninstall the old version to let me reinstall (kept saying uninstall failed). Finally, after some reading, I stopped the process, deleted the /system/app/Swype.apk and /system/lib/ via terminal emulator, and rebooted the phone. Swype was gone now from the processes, so tried to install from the Swype.apk again. Install "succeeded" and the option to activate swype was now present... but once activated, still would not work. Additionally, each time I rebooted the phone I got an error that swype had an error and had to force close. So, I uninstalled swype, and downloaded the swype beta installer. Install went through, option to activate swype is present in Language&Keyboard, but still does not work. At this point I was frustrated, so I went back into bootstrapper, cleared the phone and reinstalled rubix again fresh (same version) and went right to the swype beta installer, and still no luck. Finally, I gave up, and decided to seek some knowledge from those with more experience and know-how than I currently have.

So, does anyone have any ideas what is going on here? I can't seem to find anyone else who has had problems of this magnitude with swype! Other than this swype issue, I love the phone like this, and would rather not go back... but I'm really far too dependent on swype. Thanks for the help!