Phone won't flash/recover/anything


New Member
Aug 24, 2012
Reaction score
I've tried many different things in alot of the threads I've read on this forum and nothing is working. I tried using the One-Click root on my Droid and it didn't work, come to find out, it was an outdated method for the Droid 3. It messed up my phone. My apps constantly crash. My texts disappear, then sometimes reappear switching the place of the texts randomly. When I reset from settings, it restarts phone, but nothing is reset. It won't let me check my e-mails(G-mail). I can hardly do anything. I've tried flashing back using the AP Fastboot method from psouza(spelling?). On my phone it says Battery OK/Program OK/USB Connected. So I run the "CLICK HERE - Flash Verizon DROID 3 OTA 5.6.890 to phone.bat" And it says this: >View attachment 55128
It then proceeds to to reboot, but nothing changes. Ever. And I've tried the Hard reset method. Nothing is working. Please help. I tried being as descriptive as possible so that it answers most potential questions.
Phone specs: Version: 5.7.906.XT862.Verizon.en.US
Android 2.3.4
The problem is you're trying to flash .890 system but you're on .906.

Go here and follow Ovelayer's .906 directions
Thank you! The file is taking forever to download, and I must go to bed, but I will post in here if is successful or not.
It says that I need to download a fresh file, that some of the files in this are corrupt. :(
*EDIT* It's only downloading a small portion of the file for some reason. Is there another link that has this file? Or can someone upload one to say... MediaFire or something with a better d/l speed. I haven't had proper use of my phone in a week. I'm dying.
Last edited:
I used that method to no avail. It seemed like everything was going smoothly. Everything in the command prompt was OKAY. Then it rebooted to finish installing files. When it rebooted, it sent me straight to the Triangle/Android screen. So I held the volume buttons and rebooted. IT CHANGED NOTHING. I just want my phone to work! :/
Everything seems to go good. And I was happy! Looked like this >>View attachment 55169
But when it rebooted, it took me to the android triangle screen. SO I selcected reboot. And absolutely nothing changed. Am I Missing a step?
*EDIT* I also tried doing it again, but after it went to traingle android screen, i selected the update from the SD card, installed it, rebooted, and STILL nothing.
Last edited: